CVE-2025-55210 FreePBX API has a Privilege Escalation Error in GraphQL Allowing Authenticated Users to Access Additional Scopes

Low 2.0 Published Updated

Authenticated users can escalate privileges by forging JWTs with full API access if they possess the signing key and a valid token ID.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2025-55210?

CVE-2025-55210 is a low-severity vulnerability in Sangoma Freepbx, published on 12 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

FreePBX is an open-source web-based graphical user interface (GUI) that manages Asterisk. Prior to 17.0.5 and 16.0.17, FreePBX module api (PBX API) is vulnerable to privilege escalation by authenticated users with REST/GraphQL API access. This vulnerability allows an attacker to forge a valid JWT with full access to the REST and GraphQL APIs on a FreePBX that they've already connected to, possibly as a lower privileged user. The JWT is signed using the api-oauth.key private key. An attacker can generate their own token if they possess this key (e.g., by accessing an affected instance), and specify any scopes they wish (e.g., rest, gql), bypassing traditional authorization checks. However, FreePBX enforces that the jti (JWT ID) claim must exist in the database (api_access_tokens table in the asterisk MySQL database) in order for the token to be accepted. Therefore, the attacker must know a jti value that already exists on the target instance. This vulnerability is fixed in 17.0.5 and 16.0.17.

Weakness: CWE-270

Which versions are affected by CVE-2025-55210?

It affects 1 product.

Products include Sangoma Freepbx.

How do I fix CVE-2025-55210?

No fix has been published for CVE-2025-55210 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-55210 being exploited?

There is no known exploitation of CVE-2025-55210 in the wild and no public exploit code.

All Sangoma Freepbx vulnerabilities

Sources

Also known as GHSA-gvgh-p7wj-76cf.

Is CVE-2025-55210 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free