# CVE-2025-55210: FreePBX API has a Privilege Escalation Error in GraphQL Allowing Authenticated Users to Access Additional Scopes

> Authenticated users can escalate privileges by forging JWTs with full API access if they possess the signing key and a valid token ID.

- **Severity:** Low 2.0 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 12 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-gvgh-p7wj-76cf

## What is CVE-2025-55210?

CVE-2025-55210 is a low-severity vulnerability in Sangoma Freepbx, published on 12 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

FreePBX is an open-source web-based graphical user interface (GUI) that manages Asterisk. Prior to 17.0.5 and 16.0.17, FreePBX module api (PBX API) is vulnerable to privilege escalation by authenticated users with REST/GraphQL API access. This vulnerability allows an attacker to forge a valid JWT with full access to the REST and GraphQL APIs on a FreePBX that they've already connected to, possibly as a lower privileged user. The JWT is signed using the api-oauth.key private key. An attacker can generate their own token if they possess this key (e.g., by accessing an affected instance), and specify any scopes they wish (e.g., rest, gql), bypassing traditional authorization checks. However, FreePBX enforces that the jti (JWT ID) claim must exist in the database (api_access_tokens table in the asterisk MySQL database) in order for the token to be accepted. Therefore, the attacker must know a jti value that already exists on the target instance. This vulnerability is fixed in 17.0.5 and 16.0.17.

Weakness: CWE-270 (Privilege Context Switching Error)

## Which versions are affected by CVE-2025-55210?

It affects 1 product.


Products: Sangoma Freepbx.

## How do I fix CVE-2025-55210?

No fix has been published for CVE-2025-55210 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-55210 being exploited?

There is no known exploitation of CVE-2025-55210 in the wild and no public exploit code.

## Other vulnerabilities in Sangoma Freepbx

- [CVE-2025-57819](https://insights.sbomify.com/CVE-2025-57819/): Sangoma FreePBX Authentication Bypass (critical 10.0, exploited in the wild)
- [CVE-2019-19006](https://insights.sbomify.com/CVE-2019-19006/): Sangoma FreePBX Improper Authentication (critical 9.8, exploited in the wild)
- [CVE-2026-73663](https://insights.sbomify.com/CVE-2026-73663/): FreePBX: Unauthenticated SQL injection in FreePBX missedcall via inbound Caller ID name leads to administrator takeover (critical 9.3)
- [CVE-2026-73665](https://insights.sbomify.com/CVE-2026-73665/): FreePBX UCP: Unauthenticated remote code execution via socket.io namespace auth bypass and AMI action injection (critical 9.3)
- [CVE-2026-46376](https://insights.sbomify.com/CVE-2026-46376/): FreePBX: Unauthenticated Use of Hard-Coded Credentials Vulnerability in FreePBX UCP Interface (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55210 and fix it if it is affected.

What it is: CVE-2025-55210 is a low-severity vulnerability in Sangoma Freepbx, published on 12 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-55210 in the wild and no public exploit code.

Affected product: Sangoma Freepbx. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55210/ (Markdown: https://insights.sbomify.com/CVE-2025-55210/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55210
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55210
- OSV: https://osv.dev/vulnerability/CVE-2025-55210

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55210/
Summaries are generated and may contain mistakes; the official description above is the record.
