CVE-2025-55211 FreePBX Post-Authenticated Command Injection

Medium 6.3 Published Updated

Authenticated administrators can execute arbitrary shell commands via the framework module language settings in FreePBX.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-55211?

CVE-2025-55211 is a medium-severity command injection vulnerability in Sangoma Freepbx, published on 15 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

FreePBX is an open-source web-based graphical user interface. From 17.0.19.11 to before 17.0.21, authenticated users of the Administrator Control Panel (ACP) can run arbitrary shell commands by maliciously changing languages of the framework module. This vulnerability is fixed in 17.0.21.

Weakness: CWE-78

Which versions are affected by CVE-2025-55211?

It affects 1 product.

Products include Sangoma Freepbx.

How do I fix CVE-2025-55211?

No fix has been published for CVE-2025-55211 yet. Limit exposure of the affected software until one is available.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2025-55211 being exploited?

There is no known exploitation of CVE-2025-55211 in the wild and no public exploit code.

All Sangoma Freepbx vulnerabilities

Sources

Also known as GHSA-xg83-m6q5-q24h.

Is CVE-2025-55211 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free