CVE-2025-55213 OpenFGA Authorization Bypass (Check)
Attackers can bypass authorization checks in OpenFGA, potentially gaining unauthorized access to protected resources.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-55213?
CVE-2025-55213 is a medium-severity authentication bypass vulnerability in openfga, published on 18 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.9.3 to v1.9.4 ( openfga-0.2.40 <= Helm chart <= openfga-0.2.41, v1.9.3 <= docker <= v.1.9.4) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. This vulnerability is fixed in 1.9.5.
Weakness: CWE-863
Which versions are affected by CVE-2025-55213?
3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
github.com/openfga/openfga Go | From 1.9.3 | 1.9.5 |
github.com/openfga/openfga Go | From 1.9.3 | 1.9.5 |
github.com/openfga/openfga Go | From 1.9.3 | 1.9.5 |
Products include Openfga Helm Charts, Openfga Openfga.
How do I fix CVE-2025-55213?
Upgrade github.com/openfga/openfga to 1.9.5 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-55213 being exploited?
There is no known exploitation of CVE-2025-55213 in the wild and no public exploit code.
Other vulnerabilities in openfga
Sources
Also known as GHSA-mgh9-4mwp-fg55, GO-2025-3894.