CVE-2025-55214 Copier safe template has filesystem write access outside destination path

Medium 6.9 Published Updated

A malicious template can write files outside the destination directory, allowing arbitrary file overwrites via path traversal in Copier.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-55214?

CVE-2025-55214 is a medium-severity path traversal vulnerability in copier-org copier, published on 18 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

Copier library and CLI app for rendering project templates. From 7.1.0 to before 9.9.1, Copier suggests that it's safe to generate a project from a safe template, i.e. one that doesn't use unsafe features like custom Jinja extensions which would require passing the --UNSAFE,--trust flag. As it turns out, a safe template can currently write files outside the destination path where a project shall be generated or updated. This is possible when rendering a generated directory structure whose rendered path is either a relative parent path or an absolute path. Constructing such paths is possible using Copier's builtin pathjoin Jinja filter and its builtin _copier_conf.sep variable, which is the platform-native path separator. This way, a malicious template author can create a template that overwrites arbitrary files (according to the user's write permissions), e.g., to cause havoc. This vulnerability is fixed in 9.9.1.

Weakness: CWE-22

Which versions are affected by CVE-2025-55214?

3 open source packages ship an affected version, including copier.

PackageAffectedFixed in
copier PyPIFrom 7.1.09.9.1
copier PyPIFrom 7.1.09.9.1
copier PyPIFrom 7.1.09.9.1

How do I fix CVE-2025-55214?

Upgrade copier to 9.9.1 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2025-55214 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55214 exists.

Sources

Also known as GHSA-p7q8-grrj-3m8w, PYSEC-2026-1273.

Is CVE-2025-55214 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free