# CVE-2025-55214: Copier safe template has filesystem write access outside destination path

> A malicious template can write files outside the destination directory, allowing arbitrary file overwrites via path traversal in Copier.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Aug 2025
- **Updated:** 18 Aug 2025
- **Also known as:** GHSA-p7q8-grrj-3m8w, PYSEC-2026-1273

## What is CVE-2025-55214?

CVE-2025-55214 is a medium-severity path traversal vulnerability in copier-org copier, published on 18 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Copier library and CLI app for rendering project templates. From 7.1.0 to before 9.9.1, Copier suggests that it's safe to generate a project from a safe template, i.e. one that doesn't use unsafe features like custom Jinja extensions which would require passing the --UNSAFE,--trust flag. As it turns out, a safe template can currently write files outside the destination path where a project shall be generated or updated. This is possible when rendering a generated directory structure whose rendered path is either a relative parent path or an absolute path. Constructing such paths is possible using Copier's builtin pathjoin Jinja filter and its builtin _copier_conf.sep variable, which is the platform-native path separator. This way, a malicious template author can create a template that overwrites arbitrary files (according to the user's write permissions), e.g., to cause havoc. This vulnerability is fixed in 9.9.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-55214?

3 open source packages ship an affected version, including copier.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `copier` | PyPI | From 7.1.0 | 9.9.1 |
| `copier` | PyPI | From 7.1.0 | 9.9.1 |
| `copier` | PyPI | From 7.1.0 | 9.9.1 |

## How do I fix CVE-2025-55214?

Upgrade copier to 9.9.1 or later.

## Is CVE-2025-55214 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55214 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55214 and fix it if it is affected.

What it is: CVE-2025-55214 is a medium-severity path traversal vulnerability in copier-org copier, published on 18 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55214 exists.

Affected packages and fixed versions:
- copier (PyPI): affected from 7.1.0; fixed in 9.9.1
- copier (PyPI): affected from 7.1.0; fixed in 9.9.1
- copier (PyPI): affected from 7.1.0; fixed in 9.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55214/ (Markdown: https://insights.sbomify.com/CVE-2025-55214/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55214
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55214
- OSV: https://osv.dev/vulnerability/CVE-2025-55214

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55214/
Summaries are generated and may contain mistakes; the official description above is the record.
