{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-55282 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-55282 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-55282 is a critical vulnerability in aiven-db-migrate, published on 18 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-55282 and fix it if it is affected.\n\nWhat it is: CVE-2025-55282 is a critical vulnerability in aiven-db-migrate, published on 18 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-55282 in the wild and no public exploit code.\n\nAffected product: aiven-db-migrate. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-55282/ (Markdown: https://insights.sbomify.com/CVE-2025-55282/index.md)","id":"CVE-2025-55282","markdown":"https://insights.sbomify.com/CVE-2025-55282/index.md","name":"CVE-2025-55282","record":{"aliases":["GHSA-hmvf-93r4-36f9"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Database migration tool","requires_auth":"high_privilege","summary":"An attacker can escalate privileges to superuser in PostgreSQL by exploiting unrestricted search_path during database migrations from untrusted sources.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"aiven-db-migrate","vendor":"aiven"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"aiven-db-migrate is an Aiven database migration tool. Prior to 1.0.7, there is a privilege escalation vulnerability that allows a user to elevate to superuser inside PostgreSQL databases during a migration from an untrusted source server. By exploiting a lack of search_path restriction, an attacker can override pg_catalog and execute untrusted operators as a superuser. This vulnerability is fixed in 1.0.7.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"aiven-db-migrate allows Privilege Escalation via unrestricted search_path during migration","id":"CVE-2025-55282","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"aiven-db-migrate allows Privilege Escalation through use of psql during migration","id":"CVE-2025-55283"},"packages":[],"prev":{"headline":"Information Disclosure Vulnerability in ZKTeco WL20","id":"CVE-2025-55280"},"products":["aiven-db-migrate"],"published":"2025-08-18","related":[{"cvss_score":9.1,"headline":"aiven-db-migrate allows Privilege Escalation through use of psql during migration","id":"CVE-2025-55283","kev_date_added":null,"published":"2025-08-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-18","vendors":["aiven"]},"summary":"An attacker can escalate privileges to superuser in PostgreSQL by exploiting unrestricted search_path during database migrations from untrusted sources.","url":"https://insights.sbomify.com/CVE-2025-55282/"}