# CVE-2025-55282: aiven-db-migrate allows Privilege Escalation via unrestricted search_path during migration

> An attacker can escalate privileges to superuser in PostgreSQL by exploiting unrestricted search_path during database migrations from untrusted sources.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Aug 2025
- **Updated:** 18 Aug 2025
- **Also known as:** GHSA-hmvf-93r4-36f9

## What is CVE-2025-55282?

CVE-2025-55282 is a critical vulnerability in aiven-db-migrate, published on 18 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

aiven-db-migrate is an Aiven database migration tool. Prior to 1.0.7, there is a privilege escalation vulnerability that allows a user to elevate to superuser inside PostgreSQL databases during a migration from an untrusted source server. By exploiting a lack of search_path restriction, an attacker can override pg_catalog and execute untrusted operators as a superuser. This vulnerability is fixed in 1.0.7.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-55282?

It affects 1 product.


Products: Aiven Aiven-Db-Migrate.

## How do I fix CVE-2025-55282?

No fix has been published for CVE-2025-55282 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-55282 being exploited?

There is no known exploitation of CVE-2025-55282 in the wild and no public exploit code.

## Other vulnerabilities in aiven-db-migrate

- [CVE-2025-55283](https://insights.sbomify.com/CVE-2025-55283/): aiven-db-migrate allows Privilege Escalation through use of psql during migration (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55282 and fix it if it is affected.

What it is: CVE-2025-55282 is a critical vulnerability in aiven-db-migrate, published on 18 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-55282 in the wild and no public exploit code.

Affected product: aiven-db-migrate. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55282/ (Markdown: https://insights.sbomify.com/CVE-2025-55282/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55282
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55282
- OSV: https://osv.dev/vulnerability/CVE-2025-55282

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55282/
Summaries are generated and may contain mistakes; the official description above is the record.
