# CVE-2025-55285: @backstage/plugin-scaffolder-backend Template Secret Leakage in Logs in Scaffolder When Using `fetch:template`

> Attackers with log access can view unredacted secrets passed to the fetch:template action in Backstage scaffolder templates.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Aug 2025
- **Updated:** 15 Aug 2025
- **Also known as:** GHSA-3x3q-ghcp-whf7

## What is CVE-2025-55285?

CVE-2025-55285 is a low-severity vulnerability in backstage, published on 15 Aug 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

@backstage/plugin-scaffolder-backend is the backend for the default Backstage software templates. Prior to version 2.1.1, duplicate logging of the input values in the fetch:template action in the Scaffolder meant that some of the secrets were not properly redacted. If ${{ secrets.x }} is not passed through to fetch:template there is no impact. This issue has been resolved in 2.1.1 of the scaffolder-backend plugin. A workaround for this issue involves Template Authors removing the use of ${{ secrets }} being used as an argument to fetch:template.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2025-55285?

2 open source packages ship an affected version, including @backstage/plugin-scaffolder-backend.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-scaffolder-backend` | npm | All versions | 2.1.1 |
| `@backstage/plugin-scaffolder-backend` | npm | All versions | 2.1.1 |

## How do I fix CVE-2025-55285?

Upgrade @backstage/plugin-scaffolder-backend to 2.1.1 or later.

## Is CVE-2025-55285 being exploited?

There is no known exploitation of CVE-2025-55285 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55285 and fix it if it is affected.

What it is: CVE-2025-55285 is a low-severity vulnerability in backstage, published on 15 Aug 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-55285 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-scaffolder-backend (npm): affected all versions; fixed in 2.1.1
- @backstage/plugin-scaffolder-backend (npm): affected all versions; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55285/ (Markdown: https://insights.sbomify.com/CVE-2025-55285/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55285
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55285
- OSV: https://osv.dev/vulnerability/CVE-2025-55285

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55285/
Summaries are generated and may contain mistakes; the official description above is the record.
