{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-55288 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-55288 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-55288 is a medium-severity cross-site scripting vulnerability in MGeurts genealogy, published on 18 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-55288 and fix it if it is affected.\n\nWhat it is: CVE-2025-55288 is a medium-severity cross-site scripting vulnerability in MGeurts genealogy, published on 18 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-55288 in the wild and no public exploit code.\n\nAffected product: MGeurts genealogy. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-55288/ (Markdown: https://insights.sbomify.com/CVE-2025-55288/index.md)","id":"CVE-2025-55288","markdown":"https://insights.sbomify.com/CVE-2025-55288/index.md","name":"CVE-2025-55288","record":{"aliases":["GHSA-3h8x-g9xj-rhwg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Genealogy PHP application","requires_auth":"low_privilege","summary":"Authenticated attackers can execute arbitrary JavaScript in other users' sessions, leading to session hijacking and data theft in the Genealogy application.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"genealogy","vendor":"kreaweb"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Genealogy is a family tree PHP application. Prior to 4.4.0, Authenticated Reflected Cross-Site Scripting (XSS) vulnerability was identified in the Genealogy application. Authenticated attackers could run arbitrary JavaScript in another user’s session, leading to session hijacking, data theft, and UI manipulation. This vulnerability is fixed in 4.4.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Genealogy has a Reflected XSS Vulnerability","id":"CVE-2025-55288","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"Chamilo: Stored Cross Site Scripting in Skills Argumentation","id":"CVE-2025-55289"},"packages":[],"prev":{"headline":"Genealogy has a stored XSS vulnerability","id":"CVE-2025-55287"},"products":["genealogy"],"published":"2025-08-18","related":[{"cvss_score":10,"headline":"Missing authorization in genealogy","id":"CVE-2026-39355","kev_date_added":null,"published":"2026-04-07"},{"cvss_score":8,"headline":"Genealogy has a stored XSS vulnerability","id":"CVE-2025-55287","kev_date_added":null,"published":"2025-08-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-18","vendors":["MGeurts"]},"summary":"Authenticated attackers can execute arbitrary JavaScript in other users' sessions, leading to session hijacking and data theft in the Genealogy application.","url":"https://insights.sbomify.com/CVE-2025-55288/"}