# CVE-2025-55288: Genealogy has a Reflected XSS Vulnerability

> Authenticated attackers can execute arbitrary JavaScript in other users' sessions, leading to session hijacking and data theft in the Genealogy application.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 18 Aug 2025
- **Updated:** 18 Aug 2025
- **Also known as:** GHSA-3h8x-g9xj-rhwg

## What is CVE-2025-55288?

CVE-2025-55288 is a medium-severity cross-site scripting vulnerability in MGeurts genealogy, published on 18 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Genealogy is a family tree PHP application. Prior to 4.4.0, Authenticated Reflected Cross-Site Scripting (XSS) vulnerability was identified in the Genealogy application. Authenticated attackers could run arbitrary JavaScript in another user’s session, leading to session hijacking, data theft, and UI manipulation. This vulnerability is fixed in 4.4.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-55288?

It affects 1 product.


Products: Kreaweb Genealogy.

## How do I fix CVE-2025-55288?

No fix has been published for CVE-2025-55288 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-55288 being exploited?

There is no known exploitation of CVE-2025-55288 in the wild and no public exploit code.

## Other vulnerabilities in MGeurts genealogy

- [CVE-2026-39355](https://insights.sbomify.com/CVE-2026-39355/): Missing authorization in genealogy (critical 10.0)
- [CVE-2025-55287](https://insights.sbomify.com/CVE-2025-55287/): Genealogy has a stored XSS vulnerability (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55288 and fix it if it is affected.

What it is: CVE-2025-55288 is a medium-severity cross-site scripting vulnerability in MGeurts genealogy, published on 18 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-55288 in the wild and no public exploit code.

Affected product: MGeurts genealogy. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55288/ (Markdown: https://insights.sbomify.com/CVE-2025-55288/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55288
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55288
- OSV: https://osv.dev/vulnerability/CVE-2025-55288

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55288/
Summaries are generated and may contain mistakes; the official description above is the record.
