# CVE-2025-55291: Shaarli allows reflected XSS via searchtags parameter

> Attackers can execute arbitrary scripts in victim browsers via the searchtags parameter in Shaarli, potentially leading to session hijacking or data theft.

- **Severity:** High 7.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Aug 2025
- **Updated:** 18 Aug 2025
- **Also known as:** DEBIAN-CVE-2025-55291, GHSA-7w7w-pw4j-265h, UBUNTU-CVE-2025-55291

## What is CVE-2025-55291?

CVE-2025-55291 is a high-severity cross-site scripting vulnerability in Shaarli, published on 18 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Shaarli is a minimalist bookmark manager and link sharing service. Prior to 0.15.0, the input string in the cloud tag page is not properly sanitized. This allows the </title> tag to be prematurely closed, leading to a reflected Cross-Site Scripting (XSS) vulnerability. This vulnerability is fixed in 0.15.0.

Weakness: CWE-87 (Improper Neutralization of Alternate XSS Syntax), CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-55291?


## How do I fix CVE-2025-55291?

Upgrade to a fixed version.

## Is CVE-2025-55291 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55291 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55291 and fix it if it is affected.

What it is: CVE-2025-55291 is a high-severity cross-site scripting vulnerability in Shaarli, published on 18 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55291 exists.

Affected product: Shaarli. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55291/ (Markdown: https://insights.sbomify.com/CVE-2025-55291/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55291
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55291
- OSV: https://osv.dev/vulnerability/CVE-2025-55291

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55291/
Summaries are generated and may contain mistakes; the official description above is the record.
