CVE-2025-55296 LibreNMS allows stored XSS in Alert Template name field

Medium 5.5 Published Updated

An admin can inject malicious JavaScript into Alert Template names, leading to stored XSS that compromises other admin accounts.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-55296?

CVE-2025-55296 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 18 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

librenms is a community-based GPL-licensed network monitoring system. A stored Cross-Site Scripting (XSS) vulnerability exists in LibreNMS (<= 25.6.0) in the Alert Template creation feature. This allows a user with the admin role to inject malicious JavaScript, which will be executed when the template is rendered, potentially compromising other admin accounts. This vulnerability is fixed in 25.8.0.

Weakness: CWE-79

Which versions are affected by CVE-2025-55296?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.

PackageAffectedFixed in
librenms/librenms PackagistAll versions25.8.0
librenms/librenms PackagistAll versions25.8.0

Products include Librenms Librenms.

How do I fix CVE-2025-55296?

Upgrade librenms/librenms to 25.8.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-55296 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55296 exists.

All Librenms Librenms vulnerabilities

Sources

Also known as GHSA-vxq6-8cwm-wj99.

Is CVE-2025-55296 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free