# CVE-2025-55299: VaulTLS has a password-based login exploit in additional user accounts

> Attackers can log in with empty passwords to user accounts created via the UI, bypassing authentication controls in VaulTLS.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Aug 2025
- **Updated:** 18 Aug 2025
- **Also known as:** GHSA-pjfr-pj3h-cw8m

## What is CVE-2025-55299?

CVE-2025-55299 is a critical authentication bypass vulnerability in 7ritn VaulTLS, published on 18 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

VaulTLS is a modern solution for managing mTLS (mutual TLS) certificates. Prior to 0.9.1, user accounts created through the User web UI have an empty but not NULL password set, attackers can use this to login with an empty password. This is combined with that fact, that previously disabling the password based login only effected the frontend, but still allowed login via the API. This vulnerability is fixed in 0.9.1.

Weakness: CWE-521 (Weak Password Requirements)

## Which versions are affected by CVE-2025-55299?


## How do I fix CVE-2025-55299?

No fix has been published for CVE-2025-55299 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-55299 being exploited?

There is no known exploitation of CVE-2025-55299 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55299 and fix it if it is affected.

What it is: CVE-2025-55299 is a critical authentication bypass vulnerability in 7ritn VaulTLS, published on 18 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-55299 in the wild and no public exploit code.

Affected product: 7ritn VaulTLS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55299/ (Markdown: https://insights.sbomify.com/CVE-2025-55299/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55299
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55299
- OSV: https://osv.dev/vulnerability/CVE-2025-55299

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55299/
Summaries are generated and may contain mistakes; the official description above is the record.
