# CVE-2025-55300: Komari Allows Cross-site WebSocket Hijacking

> Attackers can hijack WebSocket connections to execute remote code on monitored servers via CSRF-like attacks against authenticated users.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Aug 2025
- **Updated:** 18 Aug 2025
- **Also known as:** GHSA-q355-h244-969h, GO-2025-3874

## What is CVE-2025-55300?

CVE-2025-55300 is a high-severity vulnerability in komari-monitor komari, published on 18 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Komari is a lightweight, self-hosted server monitoring tool designed to provide a simple and efficient solution for monitoring server performance. Prior to 1.0.4-fix1, WebSocket upgrader has disabled origin checking, enabling Cross-Site WebSocket Hijacking (CSWSH) attacks against authenticated users. Any third party website can send requests to the terminal websocket endpoint with browser's cookies, resulting in remote code execution. This vulnerability is fixed in 1.0.4-fix1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-55300?

3 open source packages ship an affected version, including github.com/komari-monitor/komari.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/komari-monitor/komari` | Go | All versions | 0.0.0-20250809073044-53171affcaf0 |
| `github.com/komari-monitor/komari` | Go | All versions | 0.0.0-20250809073044-53171affcaf0 |
| `github.com/komari-monitor/komari` | Go | All versions | 0.0.0-20250809073044-53171affcaf0 |

## How do I fix CVE-2025-55300?

Upgrade github.com/komari-monitor/komari to 0.0.0-20250809073044-53171affcaf0 or later.

## Is CVE-2025-55300 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55300 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55300 and fix it if it is affected.

What it is: CVE-2025-55300 is a high-severity vulnerability in komari-monitor komari, published on 18 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55300 exists.

Affected packages and fixed versions:
- github.com/komari-monitor/komari (Go): affected all versions; fixed in 0.0.0-20250809073044-53171affcaf0
- github.com/komari-monitor/komari (Go): affected all versions; fixed in 0.0.0-20250809073044-53171affcaf0
- github.com/komari-monitor/komari (Go): affected all versions; fixed in 0.0.0-20250809073044-53171affcaf0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55300/ (Markdown: https://insights.sbomify.com/CVE-2025-55300/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55300
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55300
- OSV: https://osv.dev/vulnerability/CVE-2025-55300

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55300/
Summaries are generated and may contain mistakes; the official description above is the record.
