# CVE-2025-55303: Unauthorized third-party images in Astro’s _image endpoint

> Attackers can bypass third-party domain restrictions in Astro's image endpoint using protocol-relative URLs, serving unauthorized images.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2025
- **Updated:** 19 Aug 2025
- **Also known as:** GHSA-xf8x-j4p2-f749

## What is CVE-2025-55303?

CVE-2025-55303 is a medium-severity vulnerability in withastro astro, published on 19 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Astro is a web framework for content-driven websites. In versions of astro before 5.13.2 and 4.16.18, the image optimization endpoint in projects deployed with on-demand rendering allows images from unauthorized third-party domains to be served. On-demand rendered sites built with Astro include an /_image endpoint which returns optimized versions of images. A bug in impacted versions of astro allows an attacker to bypass the third-party domain restrictions by using a protocol-relative URL as the image source, e.g. /_image?href=//example.com/image.png. This vulnerability is fixed in 5.13.2 and 4.16.18.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-115 (Misinterpretation of Input)

## Which versions are affected by CVE-2025-55303?

6 open source packages ship an affected version, including astro and @astrojs/node. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `astro` | npm | All versions | 4.16.19 |
| `astro` | npm | All versions | 4.16.19 |
| `astro` | npm | From 5.0.0-alpha.0 | 5.13.2 |
| `astro` | npm | From 5.0.0-alpha.0 | 5.13.2 |
| `@astrojs/node` | npm | All versions | 9.1.1 |
| `@astrojs/node` | npm | All versions | 9.1.1 |

Products: Astro Astro.

## How do I fix CVE-2025-55303?

Upgrade astro to a fixed version for your release line: 4.16.19 or 5.13.2.

## Is CVE-2025-55303 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55303 exists.

Public exploit code:

- Astro - Unauthorized Third-Party Image Access (nuclei): http/cves/2025/CVE-2025-55303.yaml

## Other vulnerabilities in withastro astro

- [CVE-2024-56159](https://insights.sbomify.com/CVE-2024-56159/): Server source code is exposed to the public if sourcemaps are enabled (high 7.8)
- [CVE-2026-54299](https://insights.sbomify.com/CVE-2026-54299/): Astro: Host header SSRF in prerendered error page fetch (high 7.5)
- [CVE-2025-59837](https://insights.sbomify.com/CVE-2025-59837/): astro allows bypass of image proxy domain validation leading to SSRF and potential XSS (high 7.2)
- [CVE-2026-50146](https://insights.sbomify.com/CVE-2026-50146/): Astro: Reflected XSS via unescaped slot name (high 7.1)
- [CVE-2025-64764](https://insights.sbomify.com/CVE-2025-64764/): Astro is vulnerable to Reflected XSS via the server islands feature (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55303 and fix it if it is affected.

What it is: CVE-2025-55303 is a medium-severity vulnerability in withastro astro, published on 19 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55303 exists.

Affected packages and fixed versions:
- astro (npm): affected all versions; fixed in 4.16.19
- astro (npm): affected all versions; fixed in 4.16.19
- astro (npm): affected from 5.0.0-alpha.0; fixed in 5.13.2
- astro (npm): affected from 5.0.0-alpha.0; fixed in 5.13.2
- @astrojs/node (npm): affected all versions; fixed in 9.1.1
- @astrojs/node (npm): affected all versions; fixed in 9.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55303/ (Markdown: https://insights.sbomify.com/CVE-2025-55303/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55303
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55303
- OSV: https://osv.dev/vulnerability/CVE-2025-55303

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55303/
Summaries are generated and may contain mistakes; the official description above is the record.
