# CVE-2025-55304: Exiv2 has quadratic performance in ICC profile parsing in JpegBase::readMetadata

> Attackers can cause denial of service by providing crafted JPEG images that trigger quadratic time complexity in Exiv2's ICC profile parsing.

- **Severity:** Low 1.8 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Aug 2025
- **Updated:** 29 Aug 2025
- **Also known as:** AZL-66708, AZL-66767, CLSA-2025-1760106873, CLSA-2025-1766136361, DEBIAN-CVE-2025-55304, GHSA-m54q-mm9w-fp6g, JLSEC-2026-1315, PYSEC-2026-1355, SUSE-SU-2026:0231-1, USN-8103-2

## What is CVE-2025-55304?

CVE-2025-55304 is a low-severity denial of service vulnerability in Exiv2 Exiv2, published on 29 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Exiv2 is a C++ library and a command-line utility to read, write, delete and modify Exif, IPTC, XMP and ICC image metadata. A denial-of-service was found in Exiv2 version 0.28.5: a quadratic algorithm in the ICC profile parsing code in jpegBase::readMetadata() can cause Exiv2 to run for a long time. The denial-of-service is triggered when Exiv2 is used to read the metadata of a crafted jpg image file. The bug is fixed in version 0.28.6.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2025-55304?

3 open source packages ship an affected version, including exiv2 and Exiv2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `exiv2` | PyPI | All versions to 0.17.3 | None |
| `exiv2` | PyPI | All versions to 0.17.3 | None |
| `Exiv2` | PyPI | All versions to 0.17.3 | None |
| `exiv2-0_26` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 0.26-150400.9.27.1 |
| `exiv2-0_26` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 0.26-150400.9.27.1 |
| `exiv2-0_26` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 0.26-150400.9.27.1 |
| `exiv2-0_26` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 0.26-150400.9.27.1 |
| `exiv2-0_26` | openSUSE:Leap 15.6 | All versions | 0.26-150400.9.27.1 |

Products: Exiv2 Exiv2.

## How do I fix CVE-2025-55304?

Upgrade to a fixed version.

## Is CVE-2025-55304 being exploited?

There is no known exploitation of CVE-2025-55304 in the wild and no public exploit code.

## Other vulnerabilities in Exiv2 Exiv2

- [CVE-2023-44398](https://insights.sbomify.com/CVE-2023-44398/): Out-of-bounds write in exiv2 (high 8.8)
- [CVE-2019-9143](https://insights.sbomify.com/CVE-2019-9143/): Denial of service in n/a (high 8.8)
- [CVE-2019-9144](https://insights.sbomify.com/CVE-2019-9144/): Denial of service in n/a (high 8.8)
- [CVE-2018-14046](https://insights.sbomify.com/CVE-2018-14046/): Memory corruption in n/a (high 8.8)
- [CVE-2017-12955](https://insights.sbomify.com/CVE-2017-12955/): Memory corruption in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55304 and fix it if it is affected.

What it is: CVE-2025-55304 is a low-severity denial of service vulnerability in Exiv2 Exiv2, published on 29 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-55304 in the wild and no public exploit code.

Affected packages and fixed versions:
- exiv2 (PyPI): affected all versions up to 0.17.3; no fix listed
- exiv2 (PyPI): affected all versions up to 0.17.3; no fix listed
- Exiv2 (PyPI): affected all versions up to 0.17.3; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55304/ (Markdown: https://insights.sbomify.com/CVE-2025-55304/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55304
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55304
- OSV: https://osv.dev/vulnerability/CVE-2025-55304

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55304/
Summaries are generated and may contain mistakes; the official description above is the record.
