CVE-2025-55305 Electron is vulnerable to Code Injection via resource modification
Attackers can execute arbitrary code by modifying resources in Electron apps with specific integrity fuses enabled, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-55305?
CVE-2025-55305 is a medium-severity code injection vulnerability in electron, published on 4 Sep 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Electron is a framework for writing cross-platform desktop applications using JavaScript, HTML and CSS. In versions below 35.7.5, 36.0.0-alpha.1 through 36.8.0, 37.0.0-alpha.1 through 37.3.1 and 38.0.0-alpha.1 through 38.0.0-beta.6, ASAR Integrity Bypass via resource modification. This only impacts apps that have the embeddedAsarIntegrityValidation and onlyLoadAppFromAsar fuses enabled. Apps without these fuses enabled are not impacted. This issue is fixed in versions 35.7.5, 36.8.1, 37.3.1 and 38.0.0-beta.6.
Which versions are affected by CVE-2025-55305?
8 open source packages ship an affected version, including electron.
| Package | Affected | Fixed in |
|---|---|---|
electron npm | All versions | 35.7.5 |
electron npm | All versions | 35.7.5 |
electron npm | From 36.0.0-alpha.1 | 36.8.1 |
electron npm | From 36.0.0-alpha.1 | 36.8.1 |
electron npm | From 37.0.0-alpha.1 | 37.3.1 |
electron npm | From 37.0.0-alpha.1 | 37.3.1 |
2 more packages
electron npm | From 38.0.0-alpha.1 | 38.0.0-beta.6 |
electron npm | From 38.0.0-alpha.1 | 38.0.0-beta.6 |
How do I fix CVE-2025-55305?
Upgrade electron to a fixed version for your release line: 35.7.5, 36.8.1, 37.3.1 or 38.0.0-beta.6.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2025-55305 being exploited?
There is no known exploitation of CVE-2025-55305 in the wild and no public exploit code.
Sources
Also known as GHSA-vmqv-hx8q-j7mg.