# CVE-2025-55305: Electron is vulnerable to Code Injection via resource modification

> Attackers can execute arbitrary code by modifying resources in Electron apps with specific integrity fuses enabled, requiring an upgrade to patched versions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Sep 2025
- **Updated:** 5 Sep 2025
- **Also known as:** GHSA-vmqv-hx8q-j7mg

## What is CVE-2025-55305?

CVE-2025-55305 is a medium-severity code injection vulnerability in electron, published on 4 Sep 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Electron is a framework for writing cross-platform desktop applications using JavaScript, HTML and CSS. In versions below 35.7.5, 36.0.0-alpha.1 through 36.8.0, 37.0.0-alpha.1 through 37.3.1 and 38.0.0-alpha.1 through 38.0.0-beta.6, ASAR Integrity Bypass via resource modification. This only impacts apps that have the embeddedAsarIntegrityValidation and onlyLoadAppFromAsar fuses enabled. Apps without these fuses enabled are not impacted. This issue is fixed in versions 35.7.5, 36.8.1, 37.3.1 and 38.0.0-beta.6.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2025-55305?

8 open source packages ship an affected version, including electron.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | All versions | 35.7.5 |
| `electron` | npm | All versions | 35.7.5 |
| `electron` | npm | From 36.0.0-alpha.1 | 36.8.1 |
| `electron` | npm | From 36.0.0-alpha.1 | 36.8.1 |
| `electron` | npm | From 37.0.0-alpha.1 | 37.3.1 |
| `electron` | npm | From 37.0.0-alpha.1 | 37.3.1 |
| `electron` | npm | From 38.0.0-alpha.1 | 38.0.0-beta.6 |
| `electron` | npm | From 38.0.0-alpha.1 | 38.0.0-beta.6 |

## How do I fix CVE-2025-55305?

Upgrade electron to a fixed version for your release line: 35.7.5, 36.8.1, 37.3.1 or 38.0.0-beta.6.

## Is CVE-2025-55305 being exploited?

There is no known exploitation of CVE-2025-55305 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55305 and fix it if it is affected.

What it is: CVE-2025-55305 is a medium-severity code injection vulnerability in electron, published on 4 Sep 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-55305 in the wild and no public exploit code.

Affected packages and fixed versions:
- electron (npm): affected all versions; fixed in 35.7.5
- electron (npm): affected all versions; fixed in 35.7.5
- electron (npm): affected from 36.0.0-alpha.1; fixed in 36.8.1
- electron (npm): affected from 36.0.0-alpha.1; fixed in 36.8.1
- electron (npm): affected from 37.0.0-alpha.1; fixed in 37.3.1
- electron (npm): affected from 37.0.0-alpha.1; fixed in 37.3.1
- electron (npm): affected from 38.0.0-alpha.1; fixed in 38.0.0-beta.6
- electron (npm): affected from 38.0.0-alpha.1; fixed in 38.0.0-beta.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55305/ (Markdown: https://insights.sbomify.com/CVE-2025-55305/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55305
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55305
- OSV: https://osv.dev/vulnerability/CVE-2025-55305

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55305/
Summaries are generated and may contain mistakes; the official description above is the record.
