# CVE-2025-55449: AstrBot is vulnerable to RCE with hard-coded JWT signing keys

> AstrBot uses a hardcoded private key for JWT signing, allowing attackers to forge tokens and bypass authentication or take over accounts.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 8 May 2026
- **Also known as:** GHSA-4m32-cjv7-f425, PYSEC-2026-285

## What is CVE-2025-55449?

CVE-2025-55449 is a high-severity vulnerability in n/a, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

AstrBotDevs AstrBot 3.5.15 has Advanced_System_for_Text_Response_and_Bot_Operations_Tool as the hardcoded private key used to sign a JWT.

Weakness: CWE-321 (Use of Hard-coded Cryptographic Key)

## Which versions are affected by CVE-2025-55449?

3 open source packages ship an affected version, including astrbot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `astrbot` | PyPI | All versions | 3.5.18 |
| `astrbot` | PyPI | All versions | 3.5.18 |
| `astrbot` | PyPI | All versions | 3.5.18 |

Products: Astrbot Astrbot.

## How do I fix CVE-2025-55449?

Upgrade astrbot to 3.5.18 or later.

## Is CVE-2025-55449 being exploited?

There is no known exploitation of CVE-2025-55449 in the wild and no public exploit code.

Public exploit code:

- CVE-2025-55449 EXP (github_poc): https://github.com/xhh1h/CVE-2025-55449
- AstrBot老版本RCE (github_poc): https://github.com/Marven11/CVE-2025-55449-AstrBot-RCE

## Other vulnerabilities in n/a

- [CVE-2025-57698](https://insights.sbomify.com/CVE-2025-57698/): AstrBot contains a directory traversal vulnerability (high 7.5)
- [CVE-2025-48957](https://insights.sbomify.com/CVE-2025-48957/): AstrBot Has Path Traversal Vulnerability in /api/chat/get_file (high 7.5)
- [CVE-2025-57697](https://insights.sbomify.com/CVE-2025-57697/): AstrBot has an arbitrary file read vulnerability in function _encode_image_bs64 (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55449 and fix it if it is affected.

What it is: CVE-2025-55449 is a high-severity vulnerability in n/a, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-55449 in the wild and no public exploit code.

Affected packages and fixed versions:
- astrbot (PyPI): affected all versions; fixed in 3.5.18
- astrbot (PyPI): affected all versions; fixed in 3.5.18
- astrbot (PyPI): affected all versions; fixed in 3.5.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55449/ (Markdown: https://insights.sbomify.com/CVE-2025-55449/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55449
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55449
- OSV: https://osv.dev/vulnerability/CVE-2025-55449

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55449/
Summaries are generated and may contain mistakes; the official description above is the record.
