{"answers":{"affected":"2 open source packages ship an affected version, including pytorch and torch. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55553 exists.","fix":"Upgrade pytorch to 2.7.1 or later.","what":"CVE-2025-55553 is a high-severity denial of service vulnerability in n/a, published on 25 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-55553 and fix it if it is affected.\n\nWhat it is: CVE-2025-55553 is a high-severity denial of service vulnerability in n/a, published on 25 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55553 exists.\n\nAffected packages and fixed versions:\n- pytorch (Bitnami): affected all versions; fixed in 2.7.1\n- torch (PyPI): affected all versions; fixed in 2.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-55553/ (Markdown: https://insights.sbomify.com/CVE-2025-55553/index.md)","id":"CVE-2025-55553","markdown":"https://insights.sbomify.com/CVE-2025-55553/index.md","name":"CVE-2025-55553","record":{"aliases":["BIT-pytorch-2025-55553","DEBIAN-CVE-2025-55553","ECHO-021d-01cc-2164","GHSA-2qm5-pr8v-rjvp","PYSEC-2025-205","UBUNTU-CVE-2025-55553"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PyTorch machine learning library","requires_auth":"none","summary":"Attackers can cause a Denial of Service in PyTorch due to a syntax error in proxy_tensor.py, affecting users of the library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pytorch","vendor":"linuxfoundation"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"}],"description":"A syntax error in the component proxy_tensor.py of pytorch v2.7.0 allows attackers to cause a Denial of Service (DoS).","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2025-55553","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Integer overflow in n/a","id":"CVE-2025-55554"},"packages":[{"ecosystem":"Bitnami","fixed":["2.7.1"],"introduced":["0"],"last_affected":[],"package":"pytorch","purl":"pkg:bitnami/pytorch","source":"BIT-pytorch-2025-55553"},{"ecosystem":"PyPI","fixed":["2.7.1"],"introduced":["0"],"last_affected":[],"package":"torch","purl":"pkg:pypi/torch","source":"PYSEC-2025-205"}],"prev":{"headline":"Integer overflow in n/a","id":"CVE-2025-55552"},"products":["n/a"],"published":"2025-09-25","related":[{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2024-48063","kev_date_added":null,"published":"2024-10-29"},{"cvss_score":9.8,"headline":"PyTorch vulnerable to arbitrary code execution","id":"CVE-2022-45907","kev_date_added":null,"published":"2022-11-26"},{"cvss_score":9.3,"headline":"PyTorch: `torch.load` with `weights_only=True` leads to remote code execution","id":"CVE-2025-32434","kev_date_added":null,"published":"2025-04-18"},{"cvss_score":8.8,"headline":"PyTorch Vulnerable to Remote Code Execution via Untrusted Checkpoint Files","id":"CVE-2026-24747","kev_date_added":null,"published":"2026-01-27"},{"cvss_score":7.8,"headline":"Pytorch use-after-free vulnerability","id":"CVE-2024-31583","kev_date_added":null,"published":"2024-04-17"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2025-55551","kev_date_added":null,"published":"2025-09-25"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-29","vendors":["n/a"]},"summary":"Attackers can cause a Denial of Service in PyTorch due to a syntax error in proxy_tensor.py, affecting users of the library.","url":"https://insights.sbomify.com/CVE-2025-55553/"}