# CVE-2025-55553: Denial of service in n/a

> Attackers can cause a Denial of Service in PyTorch due to a syntax error in proxy_tensor.py, affecting users of the library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2025
- **Updated:** 29 Sep 2025
- **Also known as:** BIT-pytorch-2025-55553, DEBIAN-CVE-2025-55553, ECHO-021d-01cc-2164, GHSA-2qm5-pr8v-rjvp, PYSEC-2025-205, UBUNTU-CVE-2025-55553

## What is CVE-2025-55553?

CVE-2025-55553 is a high-severity denial of service vulnerability in n/a, published on 25 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A syntax error in the component proxy_tensor.py of pytorch v2.7.0 allows attackers to cause a Denial of Service (DoS).

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2025-55553?

2 open source packages ship an affected version, including pytorch and torch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pytorch` | Bitnami | All versions | 2.7.1 |
| `torch` | PyPI | All versions | 2.7.1 |

Products: Linuxfoundation Pytorch.

## How do I fix CVE-2025-55553?

Upgrade pytorch to 2.7.1 or later.

## Is CVE-2025-55553 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55553 exists.

## Other vulnerabilities in n/a

- [CVE-2024-48063](https://insights.sbomify.com/CVE-2024-48063/): Deserialization in n/a (critical 9.8)
- [CVE-2022-45907](https://insights.sbomify.com/CVE-2022-45907/): PyTorch vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2025-32434](https://insights.sbomify.com/CVE-2025-32434/): PyTorch: `torch.load` with `weights_only=True` leads to remote code execution (critical 9.3)
- [CVE-2026-24747](https://insights.sbomify.com/CVE-2026-24747/): PyTorch Vulnerable to Remote Code Execution via Untrusted Checkpoint Files (high 8.8)
- [CVE-2024-31583](https://insights.sbomify.com/CVE-2024-31583/): Pytorch use-after-free vulnerability (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55553 and fix it if it is affected.

What it is: CVE-2025-55553 is a high-severity denial of service vulnerability in n/a, published on 25 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55553 exists.

Affected packages and fixed versions:
- pytorch (Bitnami): affected all versions; fixed in 2.7.1
- torch (PyPI): affected all versions; fixed in 2.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55553/ (Markdown: https://insights.sbomify.com/CVE-2025-55553/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55553
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55553
- OSV: https://osv.dev/vulnerability/CVE-2025-55553

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55553/
Summaries are generated and may contain mistakes; the official description above is the record.
