# CVE-2025-55558: Denial of service in n/a

> A buffer overflow in PyTorch's Inductor compiler can cause a denial of service when processing specific model structures.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2025
- **Updated:** 26 Sep 2025
- **Also known as:** BIT-pytorch-2025-55558, DEBIAN-CVE-2025-55558, ECHO-e906-bdf3-3976, GHSA-79pg-rrp8-8wqm, PYSEC-2025-208, UBUNTU-CVE-2025-55558

## What is CVE-2025-55558?

CVE-2025-55558 is a high-severity denial of service vulnerability in n/a, published on 25 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A buffer overflow occurs in pytorch v2.7.0 when a PyTorch model consists of torch.nn.Conv2d, torch.nn.functional.hardshrink, and torch.Tensor.view-torch.mv() and is compiled by Inductor, leading to a Denial of Service (DoS).

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-55558?

2 open source packages ship an affected version, including pytorch and torch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pytorch` | Bitnami | All versions | 2.7.1 |
| `torch` | PyPI | All versions | 2.7.1 |

Products: Linuxfoundation Pytorch.

## How do I fix CVE-2025-55558?

Upgrade pytorch to 2.7.1 or later.

## Is CVE-2025-55558 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55558 exists.

## Other vulnerabilities in n/a

- [CVE-2024-48063](https://insights.sbomify.com/CVE-2024-48063/): Deserialization in n/a (critical 9.8)
- [CVE-2022-45907](https://insights.sbomify.com/CVE-2022-45907/): PyTorch vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2025-32434](https://insights.sbomify.com/CVE-2025-32434/): PyTorch: `torch.load` with `weights_only=True` leads to remote code execution (critical 9.3)
- [CVE-2026-24747](https://insights.sbomify.com/CVE-2026-24747/): PyTorch Vulnerable to Remote Code Execution via Untrusted Checkpoint Files (high 8.8)
- [CVE-2024-31583](https://insights.sbomify.com/CVE-2024-31583/): Pytorch use-after-free vulnerability (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55558 and fix it if it is affected.

What it is: CVE-2025-55558 is a high-severity denial of service vulnerability in n/a, published on 25 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55558 exists.

Affected packages and fixed versions:
- pytorch (Bitnami): affected all versions; fixed in 2.7.1
- torch (PyPI): affected all versions; fixed in 2.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55558/ (Markdown: https://insights.sbomify.com/CVE-2025-55558/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55558
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55558
- OSV: https://osv.dev/vulnerability/CVE-2025-55558

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55558/
Summaries are generated and may contain mistakes; the official description above is the record.
