{"answers":{"affected":"1 open source package ship an affected version, including tensorflow. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55559 exists.","fix":"Upgrade tensorflow to 2.18.1 or later.","what":"CVE-2025-55559 is a high-severity denial of service vulnerability in Google Tensorflow, published on 25 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-55559 and fix it if it is affected.\n\nWhat it is: CVE-2025-55559 is a high-severity denial of service vulnerability in Google Tensorflow, published on 25 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55559 exists.\n\nAffected packages and fixed versions:\n- tensorflow (Bitnami): affected from 2.18.0; fixed in 2.18.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-55559/ (Markdown: https://insights.sbomify.com/CVE-2025-55559/index.md)","id":"CVE-2025-55559","markdown":"https://insights.sbomify.com/CVE-2025-55559/index.md","name":"CVE-2025-55559","record":{"aliases":["BIT-tensorflow-2025-55559","DEBIAN-CVE-2025-55559","GHSA-49v8-592x-2x5p","UBUNTU-CVE-2025-55559"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"TensorFlow library","requires_auth":"none","summary":"Attackers can cause a Denial of Service in TensorFlow by configuring Conv2D layers with valid padding, affecting applications using this library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"tensorflow","vendor":"google"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"An issue was discovered TensorFlow v2.18.0. A Denial of Service (DoS) occurs when padding is set to 'valid' in tf.keras.layers.Conv2D.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2025-55559","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"google:tensorflow","products":["google:tensorflow"],"type":"denial_of_service","year":"2025"},"n_packages":1,"n_references":2,"next":{"headline":"Denial of service in n/a","id":"CVE-2025-55560"},"packages":[{"ecosystem":"Bitnami","fixed":["2.18.1"],"introduced":["2.18.0"],"last_affected":[],"package":"tensorflow","purl":"pkg:bitnami/tensorflow","source":"BIT-tensorflow-2025-55559"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2025-55558"},"products":["n/a"],"published":"2025-09-25","related":[{"cvss_score":9.8,"headline":"TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation","id":"CVE-2023-25668","kev_date_added":null,"published":"2023-03-24"},{"cvss_score":9.8,"headline":"Integer Overflow or Wraparound in Google TensorFlow","id":"CVE-2018-7575","kev_date_added":null,"published":"2019-04-24"},{"cvss_score":9.3,"headline":"Arbitrary code execution due to YAML deserialization","id":"CVE-2021-37678","kev_date_added":null,"published":"2021-08-12"},{"cvss_score":9.1,"headline":"Path traversal in n/a","id":"CVE-2021-35958","kev_date_added":null,"published":"2021-06-30"},{"cvss_score":9,"headline":"Integer truncation in Shard API usage","id":"CVE-2020-15202","kev_date_added":null,"published":"2020-09-25"},{"cvss_score":9,"headline":"Data leak in Tensorflow","id":"CVE-2020-15205","kev_date_added":null,"published":"2020-09-25"},{"cvss_score":9,"headline":"Denial of Service in Tensorflow","id":"CVE-2020-15206","kev_date_added":null,"published":"2020-09-25"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-29","vendors":["n/a"]},"summary":"Attackers can cause a Denial of Service in TensorFlow by configuring Conv2D layers with valid padding, affecting applications using this library.","url":"https://insights.sbomify.com/CVE-2025-55559/"}