CVE-2025-55668 Apache Tomcat: session fixation via rewrite valve
Attackers can hijack user sessions in Apache Tomcat when the rewrite valve is enabled, leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-55668?
CVE-2025-55668 is a medium-severity authentication bypass vulnerability in Apache Tomcat, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Session Fixation vulnerability in Apache Tomcat via rewrite valve.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0-M1 through 10.1.41, from 9.0.0.M1 through 9.0.105. Older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.
Weakness: CWE-384
Which versions are affected by CVE-2025-55668?
13 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-catalina. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.42 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.42 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.8 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.8 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0.M1 | 9.0.106 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0.M1 | 9.0.106 |
7 more packages
tomcat Bitnami | All versions | 9.0.106, 10.1.42, 11.0.8 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.42 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.42 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.8 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.8 |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.0.M1 | 9.0.106 |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.0.M1 | 9.0.106 |
Products include Apache Tomcat.
How do I fix CVE-2025-55668?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.42, 11.0.8 or 9.0.106.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-55668 being exploited?
There is no known exploitation of CVE-2025-55668 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2025-55668, DEBIAN-CVE-2025-55668, GHSA-23hv-mwm6-g8jf, ROOT-APP-MAVEN-CVE-2025-55668, UBUNTU-CVE-2025-55668.