# CVE-2025-55668: Apache Tomcat: session fixation via rewrite valve

> Attackers can hijack user sessions in Apache Tomcat when the rewrite valve is enabled, leading to account takeover.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Aug 2025
- **Updated:** 4 Nov 2025
- **Also known as:** BIT-tomcat-2025-55668, DEBIAN-CVE-2025-55668, GHSA-23hv-mwm6-g8jf, ROOT-APP-MAVEN-CVE-2025-55668, UBUNTU-CVE-2025-55668

## What is CVE-2025-55668?

CVE-2025-55668 is a medium-severity authentication bypass vulnerability in Apache Tomcat, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Session Fixation vulnerability in Apache Tomcat via rewrite valve.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0-M1 through 10.1.41, from 9.0.0.M1 through 9.0.105.
Older, EOL versions may also be affected.

Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2025-55668?

13 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-catalina. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.0-M1 | 10.1.42 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.0-M1 | 10.1.42 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M1 | 11.0.8 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M1 | 11.0.8 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.0.M1 | 9.0.106 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.0.M1 | 9.0.106 |
| `tomcat` | Bitnami | All versions | 9.0.106, 10.1.42, 11.0.8 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 10.1.0-M1 | 10.1.42 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 10.1.0-M1 | 10.1.42 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 11.0.0-M1 | 11.0.8 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 11.0.0-M1 | 11.0.8 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 9.0.0.M1 | 9.0.106 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 9.0.0.M1 | 9.0.106 |

Products: Apache Tomcat.

## How do I fix CVE-2025-55668?

Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.42, 11.0.8 or 9.0.106.

## Is CVE-2025-55668 being exploited?

There is no known exploitation of CVE-2025-55668 in the wild and no public exploit code.

Public exploit code:

- Apache Tomcat - Session fixation via rewrite valve (github_poc): https://github.com/gregk4sec/CVE-2025-55668

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55668 and fix it if it is affected.

What it is: CVE-2025-55668 is a medium-severity authentication bypass vulnerability in Apache Tomcat, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-55668 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.0-M1; fixed in 10.1.42
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.0-M1; fixed in 10.1.42
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M1; fixed in 11.0.8
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M1; fixed in 11.0.8
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.0.M1; fixed in 9.0.106
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.0.M1; fixed in 9.0.106
- tomcat (Bitnami): affected all versions; fixed in 9.0.106, 10.1.42, 11.0.8
- org.apache.tomcat:tomcat-catalina (Maven): affected from 10.1.0-M1; fixed in 10.1.42
- org.apache.tomcat:tomcat-catalina (Maven): affected from 10.1.0-M1; fixed in 10.1.42
- org.apache.tomcat:tomcat-catalina (Maven): affected from 11.0.0-M1; fixed in 11.0.8
- org.apache.tomcat:tomcat-catalina (Maven): affected from 11.0.0-M1; fixed in 11.0.8
- org.apache.tomcat:tomcat-catalina (Maven): affected from 9.0.0.M1; fixed in 9.0.106

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55668/ (Markdown: https://insights.sbomify.com/CVE-2025-55668/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55668
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55668
- OSV: https://osv.dev/vulnerability/CVE-2025-55668

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55668/
Summaries are generated and may contain mistakes; the official description above is the record.
