{"answers":{"affected":"3 open source packages ship an affected version, including tkeasygui and TkEasyGUI.","exploited":"There is no known exploitation of CVE-2025-55671 in the wild and no public exploit code.","fix":"Upgrade tkeasygui to 1.0.22 or later.","what":"CVE-2025-55671 is a high-severity code injection vulnerability in kujirahand TkEasyGUI, published on 5 Sep 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-55671 and fix it if it is affected.\n\nWhat it is: CVE-2025-55671 is a high-severity code injection vulnerability in kujirahand TkEasyGUI, published on 5 Sep 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-55671 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tkeasygui (PyPI): affected all versions; fixed in 1.0.22\n- tkeasygui (PyPI): affected all versions; fixed in 1.0.22\n- TkEasyGUI (PyPI): affected all versions; fixed in 1.0.22\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-55671/ (Markdown: https://insights.sbomify.com/CVE-2025-55671/index.md)","id":"CVE-2025-55671","markdown":"https://insights.sbomify.com/CVE-2025-55671/index.md","name":"CVE-2025-55671","record":{"aliases":["GHSA-ph2w-cx28-vhrq","PYSEC-2026-1968"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python GUI library","requires_auth":"none","summary":"An attacker can execute arbitrary code via an uncontrolled search path element in TkEasyGUI, requiring an upgrade to secure the application.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jpcert","cpe":[],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-427","name":"Uncontrolled Search Path Element"}],"description":"Uncontrolled search path element issue exists in TkEasyGUI versions prior to v1.0.22. If this vulnerability is exploited, arbitrary code may be executed with the privilege of running the program.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"TkEasyGUI Affected by Uncontrolled Search Path Element Issue","id":"CVE-2025-55671","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Apache Superset: Stored XSS on charts metadata","id":"CVE-2025-55672"},"packages":[{"ecosystem":"PyPI","fixed":["1.0.22"],"introduced":["0"],"last_affected":[],"package":"TkEasyGUI","purl":null,"source":"GHSA-ph2w-cx28-vhrq"},{"ecosystem":"PyPI","fixed":["1.0.22"],"introduced":["0"],"last_affected":[],"package":"tkeasygui","purl":"pkg:pypi/tkeasygui","source":"GHSA-ph2w-cx28-vhrq"},{"ecosystem":"PyPI","fixed":["1.0.22"],"introduced":["0"],"last_affected":[],"package":"tkeasygui","purl":"pkg:pypi/tkeasygui","source":"PYSEC-2026-1968"}],"prev":{"headline":"BIG-IP Next (CNF, SPK, and Kubernetes) vulnerability","id":"CVE-2025-55670"},"products":["TkEasyGUI"],"published":"2025-09-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-09-05","vendors":["kujirahand"]},"summary":"An attacker can execute arbitrary code via an uncontrolled search path element in TkEasyGUI, requiring an upgrade to secure the application.","url":"https://insights.sbomify.com/CVE-2025-55671/"}