{"answers":{"affected":"4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-55672 in the wild and no public exploit code.","fix":"Upgrade apache-superset to 5.0.0 or later.","what":"CVE-2025-55672 is a medium-severity cross-site scripting vulnerability in Apache Superset, published on 14 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-55672 and fix it if it is affected.\n\nWhat it is: CVE-2025-55672 is a medium-severity cross-site scripting vulnerability in Apache Superset, published on 14 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-55672 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-superset (PyPI): affected all versions; fixed in 5.0.0\n- apache-superset (PyPI): affected all versions; fixed in 5.0.0\n- apache-superset (PyPI): affected all versions; fixed in 5.0.0\n- superset (Bitnami): affected all versions; fixed in 5.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-55672/ (Markdown: https://insights.sbomify.com/CVE-2025-55672/index.md)","id":"CVE-2025-55672","markdown":"https://insights.sbomify.com/CVE-2025-55672/index.md","name":"CVE-2025-55672","record":{"aliases":["BIT-superset-2025-55672","GHSA-fj97-2v9x-w5m4","PYSEC-2026-1176"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Superset","requires_auth":"low_privilege","summary":"Authenticated users can inject malicious scripts into chart labels, leading to code execution or session hijacking when victims hover over charts.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"superset","vendor":"apache"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"}],"description":"A stored Cross-Site Scripting (XSS) vulnerability exists in Apache Superset's chart visualization. An authenticated user with permissions to edit charts can inject a malicious payload into a column's label. The payload is not properly sanitized and gets executed in the victim's browser when they hover over the chart, potentially leading to session hijacking or the execution of arbitrary commands on behalf of the user.\n\nThis issue affects Apache Superset: before 5.0.0.\n\nUsers are recommended to upgrade to version 5.0.0, which fixes the issue.","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Superset: Stored XSS on charts metadata","id":"CVE-2025-55672","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:superset","products":["apache:superset"],"type":"xss","year":"2025"},"n_packages":4,"n_references":1,"next":{"headline":"Apache Superset: Metadata exposure in embedded charts","id":"CVE-2025-55673"},"packages":[{"ecosystem":"Bitnami","fixed":["5.0.0"],"introduced":["0"],"last_affected":[],"package":"superset","purl":"pkg:bitnami/superset","source":"BIT-superset-2025-55672"},{"ecosystem":"PyPI","fixed":["5.0.0"],"introduced":["0"],"last_affected":[],"package":"apache-superset","purl":null,"source":"GHSA-fj97-2v9x-w5m4"},{"ecosystem":"PyPI","fixed":["5.0.0"],"introduced":["0"],"last_affected":[],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"GHSA-fj97-2v9x-w5m4"},{"ecosystem":"PyPI","fixed":["5.0.0"],"introduced":["0"],"last_affected":[],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"PYSEC-2026-1176"}],"prev":{"headline":"TkEasyGUI Affected by Uncontrolled Search Path Element Issue","id":"CVE-2025-55671"},"products":["Apache Superset"],"published":"2025-08-14","related":[{"cvss_score":8.9,"headline":"Apache Superset Insecure Default Initialization of Resource","id":"CVE-2023-27524","kev_date_added":"2024-01-08","published":"2023-04-24"},{"cvss_score":9.8,"headline":"SQL injection vulnerability in chart data API","id":"CVE-2022-27479","kev_date_added":null,"published":"2022-04-13"},{"cvss_score":9.8,"headline":"Deserialization of Untrusted Data in superset","id":"CVE-2018-8021","kev_date_added":null,"published":"2018-11-07"},{"cvss_score":9.6,"headline":"Apache Superset: Stored XSS in Dashboard Title and Chart Title","id":"CVE-2023-49657","kev_date_added":null,"published":"2024-01-23"},{"cvss_score":8.8,"headline":"Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API","id":"CVE-2022-43719","kev_date_added":null,"published":"2023-01-16"},{"cvss_score":8.8,"headline":"Possible SQL Injection when template processing is enabled","id":"CVE-2021-41971","kev_date_added":null,"published":"2021-10-18"},{"cvss_score":8.8,"headline":"Apache Superset OS Command Injection","id":"CVE-2020-13948","kev_date_added":null,"published":"2020-09-17"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["Apache Software Foundation"]},"summary":"Authenticated users can inject malicious scripts into chart labels, leading to code execution or session hijacking when victims hover over charts.","url":"https://insights.sbomify.com/CVE-2025-55672/"}