# CVE-2025-55672: Apache Superset: Stored XSS on charts metadata

> Authenticated users can inject malicious scripts into chart labels, leading to code execution or session hijacking when victims hover over charts.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Aug 2025
- **Updated:** 4 Nov 2025
- **Also known as:** BIT-superset-2025-55672, GHSA-fj97-2v9x-w5m4, PYSEC-2026-1176

## What is CVE-2025-55672?

CVE-2025-55672 is a medium-severity cross-site scripting vulnerability in Apache Superset, published on 14 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A stored Cross-Site Scripting (XSS) vulnerability exists in Apache Superset's chart visualization. An authenticated user with permissions to edit charts can inject a malicious payload into a column's label. The payload is not properly sanitized and gets executed in the victim's browser when they hover over the chart, potentially leading to session hijacking or the execution of arbitrary commands on behalf of the user.

This issue affects Apache Superset: before 5.0.0.

Users are recommended to upgrade to version 5.0.0, which fixes the issue.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2025-55672?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 5.0.0 |
| `apache-superset` | PyPI | All versions | 5.0.0 |
| `apache-superset` | PyPI | All versions | 5.0.0 |
| `superset` | Bitnami | All versions | 5.0.0 |

Products: Apache Superset.

## How do I fix CVE-2025-55672?

Upgrade apache-superset to 5.0.0 or later.

## Is CVE-2025-55672 being exploited?

There is no known exploitation of CVE-2025-55672 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55672 and fix it if it is affected.

What it is: CVE-2025-55672 is a medium-severity cross-site scripting vulnerability in Apache Superset, published on 14 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-55672 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 5.0.0
- apache-superset (PyPI): affected all versions; fixed in 5.0.0
- apache-superset (PyPI): affected all versions; fixed in 5.0.0
- superset (Bitnami): affected all versions; fixed in 5.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55672/ (Markdown: https://insights.sbomify.com/CVE-2025-55672/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55672
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55672
- OSV: https://osv.dev/vulnerability/CVE-2025-55672

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55672/
Summaries are generated and may contain mistakes; the official description above is the record.
