CVE-2025-55732 Frappe has the possibility of SQL Injection due to improper validations

High 8.7 Published Updated

Attackers can execute SQL injection via crafted requests to access sensitive data in the Frappe web application framework.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-55732?

CVE-2025-55732 is a high-severity SQL injection vulnerability in frappe, published on 20 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Frappe is a full-stack web application framework. Prior to 15.74.2 and 14.96.15, an attacker could implement SQL injection through specially crafted requests, allowing malicious people to access sensitive information. This vulnerability is a bypass of the official patch released for CVE-2025-52895. This vulnerability is fixed in 15.74.2 and 14.96.15.

Weakness: CWE-89

Which versions are affected by CVE-2025-55732?

It affects 1 product.

Products include Frappe Frappe.

How do I fix CVE-2025-55732?

No fix has been published for CVE-2025-55732 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2025-55732 being exploited?

There is no known exploitation of CVE-2025-55732 in the wild and no public exploit code.

Sources

Also known as GHSA-6rpr-2hjx-w9vp.

Is CVE-2025-55732 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free