# CVE-2025-55739: api: Shared OAuth Signing Key Between Different Instances

> Attackers can forge JWT tokens using a shared OAuth private key to bypass authentication and gain full API access in FreePBX.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 4 Sep 2025
- **Updated:** 13 Feb 2026
- **Also known as:** GHSA-3r47-p39v-vqqf

## What is CVE-2025-55739?

CVE-2025-55739 is a medium-severity vulnerability in FreePBX api, published on 4 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

api is a module for FreePBX@, which is an open source GUI that controls and manages Asterisk© (PBX). In versions lower than 15.0.13, 16.0.2 through 16.0.14, 17.0.1 and 17.0.2, there is an identical OAuth private key used across multiple systems that installed the same FreePBX RPM or DEB package. An attacker with access to the shared OAuth private key could forge JWT tokens, bypass authentication, and potentially gain full access to both REST and GraphQL APIs. Systems with the "api" module enabled, configured and previously activated by an administrator for remote inbound connections may be affected. This issue is fixed in versions 15.0.13, 16.0.15 and 17.0.3.

Weakness: CWE-798 (Use of Hard-coded Credentials), CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2025-55739?


## How do I fix CVE-2025-55739?

No fix has been published for CVE-2025-55739 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-55739 being exploited?

There is no known exploitation of CVE-2025-55739 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55739 and fix it if it is affected.

What it is: CVE-2025-55739 is a medium-severity vulnerability in FreePBX api, published on 4 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-55739 in the wild and no public exploit code.

Affected product: FreePBX api. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55739/ (Markdown: https://insights.sbomify.com/CVE-2025-55739/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55739
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55739
- OSV: https://osv.dev/vulnerability/CVE-2025-55739

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55739/
Summaries are generated and may contain mistakes; the official description above is the record.
