# CVE-2025-55740: Default Credentials in nginx-defender Configuration Files

> Attackers can gain administrative control of nginx-defender deployments using default credentials found in example configuration files.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2025
- **Updated:** 19 Aug 2025
- **Also known as:** GHSA-pr72-8fxw-xx22, GO-2025-3896

## What is CVE-2025-55740?

CVE-2025-55740 is a medium-severity vulnerability in Anipaleja nginx-defender, published on 19 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

nginx-defender is a high-performance, enterprise-grade Web Application Firewall (WAF) and threat detection system engineered for modern web infrastructure. This is a configuration vulnerability affecting nginx-defender deployments. Example configuration files
config.yaml and docker-compose.yml contain default credentials (default_password: "change_me_please", GF_SECURITY_ADMIN_PASSWORD=admin123). If users deploy nginx-defender without changing these defaults, attackers with network access could gain administrative control, bypassing security protections. The issue is addressed in v1.5.0 and later.

Weakness: CWE-1392 (Use of Default Credentials)

## Which versions are affected by CVE-2025-55740?

3 open source packages ship an affected version, including github.com/Anipaleja/nginx-defender.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/Anipaleja/nginx-defender` | Go | All versions | 1.5.0 |
| `github.com/Anipaleja/nginx-defender` | Go | All versions | 1.5.0 |
| `github.com/Anipaleja/nginx-defender` | Go | All versions | 1.5.0 |

## How do I fix CVE-2025-55740?

Upgrade github.com/Anipaleja/nginx-defender to 1.5.0 or later.

## Is CVE-2025-55740 being exploited?

There is no known exploitation of CVE-2025-55740 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55740 and fix it if it is affected.

What it is: CVE-2025-55740 is a medium-severity vulnerability in Anipaleja nginx-defender, published on 19 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-55740 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/Anipaleja/nginx-defender (Go): affected all versions; fixed in 1.5.0
- github.com/Anipaleja/nginx-defender (Go): affected all versions; fixed in 1.5.0
- github.com/Anipaleja/nginx-defender (Go): affected all versions; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55740/ (Markdown: https://insights.sbomify.com/CVE-2025-55740/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55740
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55740
- OSV: https://osv.dev/vulnerability/CVE-2025-55740

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55740/
Summaries are generated and may contain mistakes; the official description above is the record.
