# CVE-2025-55745: UnoPim Quick Export feature is vulnerable to CSV injection

> Attackers can inject malicious formulas into exported CSV files, leading to remote code execution when victims open the files in spreadsheet applications.

- **Severity:** Low 2.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Aug 2025
- **Updated:** 22 Aug 2025
- **Also known as:** GHSA-74rg-6f92-g6wx

## What is CVE-2025-55745?

CVE-2025-55745 is a low-severity code injection vulnerability in unopim, published on 22 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

UnoPim is an open-source Product Information Management (PIM) system built on the Laravel framework. Versions 0.3.0 and prior are vulnerable to CSV injection, also known as formula injection, in the Quick Export feature. This vulnerability allows attackers to inject malicious content into exported CSV files. When the CSV file is opened in spreadsheet applications such as Microsoft Excel, the malicious input may be interpreted as a formula or command, potentially resulting in the execution of arbitrary code on the victim's device. Successful exploitation can lead to remote code execution, including the establishment of a reverse shell. Users are advised to upgrade to version 0.3.1 or later.

Weakness: CWE-1236 (Improper Neutralization of Formula Elements in a CSV File)

## Which versions are affected by CVE-2025-55745?

2 open source packages ship an affected version, including unopim/unopim. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `unopim/unopim` | Packagist | All versions | 0.3.1 |
| `unopim/unopim` | Packagist | All versions | 0.3.1 |

Products: Webkul Unopim.

## How do I fix CVE-2025-55745?

Upgrade unopim/unopim to 0.3.1 or later.

## Is CVE-2025-55745 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55745 exists.

## Other vulnerabilities in unopim

- [CVE-2025-55741](https://insights.sbomify.com/CVE-2025-55741/): unopim/unopim allows unauthorized product deletion via mass-delete endpoint (high 8.1)
- [CVE-2025-55742](https://insights.sbomify.com/CVE-2025-55742/): UnoPim Stored XSS via SVG MIME/Sanitizer Bypass (high 8.0)
- [CVE-2025-55743](https://insights.sbomify.com/CVE-2025-55743/): UnoPim vulnerable to remote code execution through Arbitrary File upload (high 7.3)
- [CVE-2025-55744](https://insights.sbomify.com/CVE-2025-55744/): UnoPim vulnerable to CSRF on Product edit feature and creation of other types (medium 6.9)
- [CVE-2024-52305](https://insights.sbomify.com/CVE-2024-52305/): UnoPim Stored XSS : Cookie hijacking through Create User function (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55745 and fix it if it is affected.

What it is: CVE-2025-55745 is a low-severity code injection vulnerability in unopim, published on 22 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55745 exists.

Affected packages and fixed versions:
- unopim/unopim (Packagist): affected all versions; fixed in 0.3.1
- unopim/unopim (Packagist): affected all versions; fixed in 0.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55745/ (Markdown: https://insights.sbomify.com/CVE-2025-55745/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55745
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55745
- OSV: https://osv.dev/vulnerability/CVE-2025-55745

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55745/
Summaries are generated and may contain mistakes; the official description above is the record.
