# CVE-2025-55746: Directus allows unauthenticated file upload and file modification due to lacking input sanitization

> Unauthenticated attackers can upload or modify files with arbitrary content, potentially leading to code execution or data tampering in Directus.

- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2025
- **Updated:** 20 Aug 2025
- **Also known as:** GHSA-mv33-9f6j-pfmc

## What is CVE-2025-55746?

CVE-2025-55746 is a critical vulnerability in Monospace Directus, published on 20 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directus is a real-time API and App dashboard for managing SQL database content. From 10.8.0 to before 11.9.3, a vulnerability exists in the file update mechanism which allows an unauthenticated actor to modify existing files with arbitrary contents (without changes being applied to the files' database-resident metadata) and / or upload new files, with arbitrary content and extensions, which won't show up in the Directus UI. This vulnerability is fixed in 11.9.3.

Weakness: CWE-73 (External Control of File Name or Path), CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2025-55746?

4 open source packages ship an affected version, including @directus/api and directus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@directus/api` | npm | From 14.1.0 | 28.0.2 |
| `@directus/api` | npm | From 14.1.0 | 28.0.2 |
| `directus` | npm | From 10.8.0 | 11.9.3 |
| `directus` | npm | From 10.8.0 | 11.9.3 |

Products: Monospace Directus.

## How do I fix CVE-2025-55746?

Upgrade @directus/api to 28.0.2 or later.

## Is CVE-2025-55746 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55746 exists.

Public exploit code:

- Presentation about CVE-2025-55746 (github_poc): https://github.com/r4bbit-r4/directus-preso
- Directus - Unauthenticated File Modification (nuclei): http/cves/2025/CVE-2025-55746.yaml

## Other vulnerabilities in Monospace Directus

- [CVE-2022-26969](https://insights.sbomify.com/CVE-2022-26969/): Insecure default value for CORS configuration (critical 9.8)
- [CVE-2026-35408](https://insights.sbomify.com/CVE-2026-35408/): Directus is Missing Cross-Origin Opener Policy (high 8.7)
- [CVE-2026-61836](https://insights.sbomify.com/CVE-2026-61836/): Directus: Authorization-dependent response served from unsegmented cache key (high 8.6)
- [CVE-2025-30353](https://insights.sbomify.com/CVE-2025-30353/): Directus's webhook trigger flows can leak sensitive data (high 8.6)
- [CVE-2026-39942](https://insights.sbomify.com/CVE-2026-39942/): Directus has a Path Traversal and Broken Access Control in File Management API (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55746 and fix it if it is affected.

What it is: CVE-2025-55746 is a critical vulnerability in Monospace Directus, published on 20 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55746 exists.

Affected packages and fixed versions:
- @directus/api (npm): affected from 14.1.0; fixed in 28.0.2
- @directus/api (npm): affected from 14.1.0; fixed in 28.0.2
- directus (npm): affected from 10.8.0; fixed in 11.9.3
- directus (npm): affected from 10.8.0; fixed in 11.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55746/ (Markdown: https://insights.sbomify.com/CVE-2025-55746/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55746
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55746
- OSV: https://osv.dev/vulnerability/CVE-2025-55746

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55746/
Summaries are generated and may contain mistakes; the official description above is the record.
