# CVE-2025-55748: XWiki Platform's configuration files can be accessed through jsx and sx endpoints

> Attackers can read sensitive configuration files via path traversal in jsx and sx endpoints, exposing system details.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Sep 2025
- **Updated:** 3 Sep 2025
- **Also known as:** GHSA-m63c-3rmg-r2cf

## What is CVE-2025-55748?

CVE-2025-55748 is a critical path traversal vulnerability in Xwiki Xwiki, published on 3 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In versions 4.2-milestone-2 through 16.10.6, configuration files are accessible through jsx and sx endpoints. It's possible to access and read configuration files by using URLs such as `http://localhost:8080/bin/ssx/Main/WebHome?resource=../../WEB-INF/xwiki.cfg&minify=false`. This is fixed in version 16.10.7.

Weakness: CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2025-55748?

2 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-skin-skinx. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-skin-skinx` | Maven | From 4.2-milestone-2 | 16.10.7 |
| `org.xwiki.platform:xwiki-platform-skin-skinx` | Maven | From 4.2-milestone-2 | 16.10.7 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-55748?

Upgrade org.xwiki.platform:xwiki-platform-skin-skinx to 16.10.7 or later.

## Is CVE-2025-55748 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55748 exists.

Public exploit code:

- XWiki Platform - Path Traversal (nuclei): http/cves/2025/CVE-2025-55748.yaml

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55748 and fix it if it is affected.

What it is: CVE-2025-55748 is a critical path traversal vulnerability in Xwiki Xwiki, published on 3 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55748 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-skin-skinx (Maven): affected from 4.2-milestone-2; fixed in 16.10.7
- org.xwiki.platform:xwiki-platform-skin-skinx (Maven): affected from 4.2-milestone-2; fixed in 16.10.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55748/ (Markdown: https://insights.sbomify.com/CVE-2025-55748/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55748
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55748
- OSV: https://osv.dev/vulnerability/CVE-2025-55748

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55748/
Summaries are generated and may contain mistakes; the official description above is the record.
