# CVE-2025-55749: The XWiki Jetty package (XJetty) allows accessing any application file through URL

> Attackers can access arbitrary files in the webapp folder, potentially exposing credentials, in XWiki instances using the XJetty package.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Dec 2025
- **Updated:** 1 Dec 2025
- **Also known as:** GHSA-53gx-j3p6-2rw9

## What is CVE-2025-55749?

CVE-2025-55749 is a high-severity path traversal vulnerability in Xwiki Xwiki, published on 1 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki is an open-source wiki software platform. From 16.7.0 to 16.10.11, 17.4.4, or 17.7.0, in an instance which is using the XWiki Jetty package (XJetty), a context is exposed to statically access any file located in the webapp/ folder. It allows accessing files which might contains credentials. Fixed in 16.10.11, 17.4.4, and 17.7.0.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-55749?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-tool-jetty-resources. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-tool-jetty-resources` | Maven | From 16.7.0 | 16.10.11 |
| `org.xwiki.platform:xwiki-platform-tool-jetty-resources` | Maven | From 16.7.0 | 16.10.11 |
| `org.xwiki.platform:xwiki-platform-tool-jetty-resources` | Maven | From 17.0.0-rc-1 | 17.4.4 |
| `org.xwiki.platform:xwiki-platform-tool-jetty-resources` | Maven | From 17.0.0-rc-1 | 17.4.4 |
| `org.xwiki.platform:xwiki-platform-tool-jetty-resources` | Maven | From 17.5.0 | 17.7.0 |
| `org.xwiki.platform:xwiki-platform-tool-jetty-resources` | Maven | From 17.5.0 | 17.7.0 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-55749?

Upgrade org.xwiki.platform:xwiki-platform-tool-jetty-resources to a fixed version for your release line: 16.10.11, 17.4.4 or 17.7.0.

## Is CVE-2025-55749 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55749 exists.

Public exploit code:

- XWiki - Information Disclosure (nuclei): http/cves/2025/CVE-2025-55749.yaml

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55749 and fix it if it is affected.

What it is: CVE-2025-55749 is a high-severity path traversal vulnerability in Xwiki Xwiki, published on 1 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55749 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-tool-jetty-resources (Maven): affected from 16.7.0; fixed in 16.10.11
- org.xwiki.platform:xwiki-platform-tool-jetty-resources (Maven): affected from 16.7.0; fixed in 16.10.11
- org.xwiki.platform:xwiki-platform-tool-jetty-resources (Maven): affected from 17.0.0-rc-1; fixed in 17.4.4
- org.xwiki.platform:xwiki-platform-tool-jetty-resources (Maven): affected from 17.0.0-rc-1; fixed in 17.4.4
- org.xwiki.platform:xwiki-platform-tool-jetty-resources (Maven): affected from 17.5.0; fixed in 17.7.0
- org.xwiki.platform:xwiki-platform-tool-jetty-resources (Maven): affected from 17.5.0; fixed in 17.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55749/ (Markdown: https://insights.sbomify.com/CVE-2025-55749/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55749
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55749
- OSV: https://osv.dev/vulnerability/CVE-2025-55749

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55749/
Summaries are generated and may contain mistakes; the official description above is the record.
