CVE-2025-55752 Apache Tomcat: Directory traversal via rewrite with possible RCE if PUT is enabled
Attackers can bypass security constraints via path traversal in rewritten URLs, potentially achieving remote code execution if PUT requests are enabled.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-55752?
CVE-2025-55752 is a high-severity path traversal vulnerability in Apache Tomcat, published on 27 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Relative Path Traversal vulnerability in Apache Tomcat.
The fix for bug 60013 introduced a regression where the rewritten URL was normalized before it was decoded. This introduced the possibility that, for rewrite rules that rewrite query parameters to the URL, an attacker could manipulate the request URI to bypass security constraints including the protection for /WEB-INF/ and /META-INF/. If PUT requests were also enabled then malicious files could be uploaded leading to remote code execution. PUT requests are normally limited to trusted users and it is considered unlikely that PUT requests would be enabled in conjunction with a rewrite that manipulated the URI.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.0.M11 through 9.0.108.
The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.6 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.
Weakness: CWE-23
Which versions are affected by CVE-2025-55752?
25 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.45 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.45 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.11 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.11 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.6 to 8.5.100 | None |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.6 to 8.5.100 | None |
19 more packages
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0-M11 | 9.0.109 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0-M11 | 9.0.109 |
tomcat Bitnami | All versions | 9.0.109, 10.1.45, 11.0.11 |
org.apache.tomcat:tomcat Maven | From 10.1.0-M1 | 10.1.45 |
org.apache.tomcat:tomcat Maven | From 10.1.0-M1 | 10.1.45 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.11 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.11 |
org.apache.tomcat:tomcat Maven | From 8.5.6 to 8.5.100 | None |
org.apache.tomcat:tomcat Maven | From 8.5.6 to 8.5.100 | None |
org.apache.tomcat:tomcat Maven | From 9.0.0-M11 | 9.0.109 |
org.apache.tomcat:tomcat Maven | From 9.0.0-M11 | 9.0.109 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.45 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.45 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.11 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.11 |
org.apache.tomcat:tomcat-catalina Maven | From 8.5.6 to 8.5.100 | None |
org.apache.tomcat:tomcat-catalina Maven | From 8.5.6 to 8.5.100 | None |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.0-M11 | 9.0.109 |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.0-M11 | 9.0.109 |
Products include Apache Tomcat.
How do I fix CVE-2025-55752?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.45, 11.0.11 or 9.0.109.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2025-55752 being exploited?
There is no known exploitation of CVE-2025-55752 in the wild and no public exploit code.
Public exploit code: 5 proofs of concept on GitHub.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2025-55752, CLSA-2025-1765903038, CLSA-2025-1766534900, CLSA-2025-1767098873, CLSA-2026-1768989206, CLSA-2026-1773879448 and 4 more.