# CVE-2025-55753: Apache HTTP Server: mod_md (ACME), unintended retry intervals

> Integer overflow in Apache mod_md causes zero-delay certificate renewal retries, leading to excessive resource consumption and potential denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Dec 2025
- **Updated:** 5 Dec 2025
- **Also known as:** ALPINE-CVE-2025-55753, ALSA-2025:23738, ALSA-2025:23739, AZL-71851, AZL-71858, AZL-71863, AZL-71870, BELL-CVE-2025-55753, BIT-apache-2025-55753, CLSA-2025-1767026442, CLSA-2026-1767629031, DEBIAN-CVE-2025-55753, GHSA-3j5h-f552-7rhh, MINI-cqqf-m5p4-rcx3, OESA-2026-1064, OESA-2026-1530, RHSA-2025:23738, RHSA-2025:23739, RHSA-2026:0029, RHSA-2026:0030, RHSA-2026:0092, RHSA-2026:0093, RHSA-2026:0094, RLSA-2025:23738, RLSA-2025:23739, UBUNTU-CVE-2025-55753

## What is CVE-2025-55753?

CVE-2025-55753 is a high-severity vulnerability in Apache Http Server, published on 5 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An integer overflow in the case of failed ACME certificate renewal leads, after a number of failures (~30 days in default configurations), to the backoff timer becoming 0. Attempts to renew the certificate then are repeated without delays until it succeeds.

This issue affects Apache HTTP Server: from 2.4.30 before 2.4.66.

Users are recommended to upgrade to version 2.4.66, which fixes the issue.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2025-55753?

1 open source package ship an affected version, including apache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.30 | 2.4.66 |
| `mod_md` | AlmaLinux:10 | All versions | 1:2.4.26-4.el10_1 |
| `mod_md` | AlmaLinux:9 | All versions | 1:2.4.26-1.el9_7.1 |
| `mod_md` | Red Hat:enterprise_linux:10.1 | All versions | 1:2.4.26-4.el10_1 |
| `mod_md-debuginfo` | Red Hat:enterprise_linux:10.1 | All versions | 1:2.4.26-4.el10_1 |
| `mod_md-debugsource` | Red Hat:enterprise_linux:10.1 | All versions | 1:2.4.26-4.el10_1 |
| `mod_md` | Red Hat:enterprise_linux:9::appstream | All versions | 1:2.4.26-1.el9_7.1 |
| `mod_md-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 1:2.4.26-1.el9_7.1 |
| `mod_md-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 1:2.4.26-1.el9_7.1 |
| `mod_md` | Red Hat:enterprise_linux_eus:10.0 | All versions | 1:2.4.26-3.el10_0.1 |
| `mod_md-debuginfo` | Red Hat:enterprise_linux_eus:10.0 | All versions | 1:2.4.26-3.el10_0.1 |
| `mod_md-debugsource` | Red Hat:enterprise_linux_eus:10.0 | All versions | 1:2.4.26-3.el10_0.1 |
| `mod_md` | Red Hat:rhel_e4s:9.0::appstream | All versions | 1:2.4.0-3.el9_0.1 |
| `mod_md-debuginfo` | Red Hat:rhel_e4s:9.0::appstream | All versions | 1:2.4.0-3.el9_0.1 |
| `mod_md-debugsource` | Red Hat:rhel_e4s:9.0::appstream | All versions | 1:2.4.0-3.el9_0.1 |
| `mod_md` | Red Hat:rhel_e4s:9.2::appstream | All versions | 1:2.4.19-1.el9_2.1 |
| `mod_md-debuginfo` | Red Hat:rhel_e4s:9.2::appstream | All versions | 1:2.4.19-1.el9_2.1 |
| `mod_md-debugsource` | Red Hat:rhel_e4s:9.2::appstream | All versions | 1:2.4.19-1.el9_2.1 |
| `mod_md` | Red Hat:rhel_eus:9.4::appstream | All versions | 1:2.4.19-1.el9_4.1 |
| `mod_md-debuginfo` | Red Hat:rhel_eus:9.4::appstream | All versions | 1:2.4.19-1.el9_4.1 |
| `mod_md-debugsource` | Red Hat:rhel_eus:9.4::appstream | All versions | 1:2.4.19-1.el9_4.1 |
| `mod_md` | Red Hat:rhel_eus:9.6::appstream | All versions | 1:2.4.26-1.el9_6.1 |
| `mod_md-debuginfo` | Red Hat:rhel_eus:9.6::appstream | All versions | 1:2.4.26-1.el9_6.1 |
| `mod_md-debugsource` | Red Hat:rhel_eus:9.6::appstream | All versions | 1:2.4.26-1.el9_6.1 |
| `mod_md` | Rocky Linux:10 | All versions | 1:2.4.26-4.el10_1 |
| `mod_md` | Rocky Linux:9 | All versions | 1:2.4.26-1.el9_7.1 |

Products: Apache Http Server.

## How do I fix CVE-2025-55753?

Upgrade apache to 2.4.66 or later.

## Is CVE-2025-55753 being exploited?

There is no known exploitation of CVE-2025-55753 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55753 and fix it if it is affected.

What it is: CVE-2025-55753 is a high-severity vulnerability in Apache Http Server, published on 5 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-55753 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.30; fixed in 2.4.66

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55753/ (Markdown: https://insights.sbomify.com/CVE-2025-55753/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55753
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55753
- OSV: https://osv.dev/vulnerability/CVE-2025-55753

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55753/
Summaries are generated and may contain mistakes; the official description above is the record.
