CVE-2025-55754 Apache Tomcat: console manipulation via escape sequences in log messages
Attackers can inject ANSI escape sequences into Tomcat logs to manipulate the console and trick administrators into executing malicious commands.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-55754?
CVE-2025-55754 is a critical vulnerability in Apache Tomcat, published on 27 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat.
Tomcat did not escape ANSI escape sequences in log messages. If Tomcat was running in a console on a Windows operating system, and the console supported ANSI escape sequences, it was possible for an attacker to use a specially crafted URL to inject ANSI escape sequences to manipulate the console and the clipboard and attempt to trick an administrator into running an attacker controlled command. While no attack vector was found, it may have been possible to mount this attack on other operating systems.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.40 through 9.0.108.
The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.60 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.
Weakness: CWE-150
Which versions are affected by CVE-2025-55754?
25 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.45 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.45 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.11 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.11 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.60 to 8.5.100 | None |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.60 to 8.5.100 | None |
19 more packages
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.40 | 9.0.109 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.40 | 9.0.109 |
tomcat Bitnami | All versions | 9.0.109, 10.1.45, 11.0.11 |
org.apache.tomcat:tomcat Maven | From 10.1.0-M1 | 10.1.45 |
org.apache.tomcat:tomcat Maven | From 10.1.0-M1 | 10.1.45 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.11 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.11 |
org.apache.tomcat:tomcat Maven | From 8.5.60 to 8.5.100 | None |
org.apache.tomcat:tomcat Maven | From 8.5.60 to 8.5.100 | None |
org.apache.tomcat:tomcat Maven | From 9.0.40 | 9.0.109 |
org.apache.tomcat:tomcat Maven | From 9.0.40 | 9.0.109 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.45 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.45 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.11 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.11 |
org.apache.tomcat:tomcat-catalina Maven | From 8.5.60 to 8.5.100 | None |
org.apache.tomcat:tomcat-catalina Maven | From 8.5.60 to 8.5.100 | None |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.40 | 9.0.109 |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.40 | 9.0.109 |
Products include Apache Tomcat.
How do I fix CVE-2025-55754?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.45, 11.0.11 or 9.0.109.
Is CVE-2025-55754 being exploited?
There is no known exploitation of CVE-2025-55754 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2025-55754, CLEANSTART-2026-NY54593, DEBIAN-CVE-2025-55754, GHSA-vfww-5hm6-hx2j, ROOT-APP-MAVEN-CVE-2025-55754, UBUNTU-CVE-2025-55754.