# CVE-2025-55988: DreamFactory has a directory traversal

> Attackers can execute directory traversal via unsanitized URI paths in DreamFactory Core, potentially reading unauthorized files.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 23 Mar 2026
- **Also known as:** GHSA-gv7f-w92j-383q

## What is CVE-2025-55988?

CVE-2025-55988 is a high-severity path traversal vulnerability in n/a, published on 20 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An issue in the component /Controllers/RestController.php of DreamFactory Core v1.0.3 allows attackers to execute a directory traversal via an unsanitized URI path.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-55988?

2 open source packages ship an affected version, including dreamfactory/df-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dreamfactory/df-core` | Packagist | All versions | 1.0.4 |
| `dreamfactory/df-core` | Packagist | All versions | 1.0.4 |

Products: Dreamfactory Dreamfactory Core.

## How do I fix CVE-2025-55988?

Upgrade dreamfactory/df-core to 1.0.4 or later.

## Is CVE-2025-55988 being exploited?

There is no known exploitation of CVE-2025-55988 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55988 and fix it if it is affected.

What it is: CVE-2025-55988 is a high-severity path traversal vulnerability in n/a, published on 20 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-55988 in the wild and no public exploit code.

Affected packages and fixed versions:
- dreamfactory/df-core (Packagist): affected all versions; fixed in 1.0.4
- dreamfactory/df-core (Packagist): affected all versions; fixed in 1.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55988/ (Markdown: https://insights.sbomify.com/CVE-2025-55988/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55988
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55988
- OSV: https://osv.dev/vulnerability/CVE-2025-55988

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55988/
Summaries are generated and may contain mistakes; the official description above is the record.
