{"answers":{"affected":"2 open source packages ship an affected version, including validator. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-56200 in the wild and no public exploit code.","fix":"Upgrade validator to 13.15.20 or later.","what":"CVE-2025-56200 is a medium-severity cross-site scripting vulnerability in n/a, published on 30 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-56200 and fix it if it is affected.\n\nWhat it is: CVE-2025-56200 is a medium-severity cross-site scripting vulnerability in n/a, published on 30 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-56200 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- validator (npm): affected all versions; fixed in 13.15.20\n- validator (npm): affected all versions; fixed in 13.15.20\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-56200/ (Markdown: https://insights.sbomify.com/CVE-2025-56200/index.md)","id":"CVE-2025-56200","markdown":"https://insights.sbomify.com/CVE-2025-56200/index.md","name":"CVE-2025-56200","record":{"aliases":["CLSA-2026-1784769499","CLSA-2026-1789161501","GHSA-9965-vmph-33xx","MINI-6hx5-73r5-8c3v","MINI-85p5-p97c-w7m9","MINI-98rp-vv2g-9x4v","ROOT-APP-NPM-CVE-2025-56200","UBUNTU-CVE-2025-56200"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript validation library","requires_auth":"none","summary":"Attackers can bypass URL validation in validator.js to execute XSS or open redirects due to protocol parsing differences with browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"validator","vendor":"validator_project"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A URL validation bypass vulnerability exists in validator.js through version 13.15.15. The isURL() function uses '://' as a delimiter to parse protocols, while browsers use ':' as the delimiter. This parsing difference allows attackers to bypass protocol and domain validation by crafting URLs leading to XSS and Open Redirect attacks.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"validator.js has a URL validation bypass vulnerability in its isURL function","id":"CVE-2025-56200","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Business logic in n/a","id":"CVE-2025-56207"},"packages":[{"ecosystem":"npm","fixed":["13.15.20"],"introduced":["0"],"last_affected":[],"package":"validator","purl":null,"source":"GHSA-9965-vmph-33xx"},{"ecosystem":"npm","fixed":["13.15.20"],"introduced":["0"],"last_affected":[],"package":"validator","purl":"pkg:npm/validator","source":"GHSA-9965-vmph-33xx"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2025-56162"},"products":["n/a"],"published":"2025-09-30","related":[{"cvss_score":8.7,"headline":"Validator is Vulnerable to Incomplete Filtering of One or More Instances of Special Elements","id":"CVE-2025-12758","kev_date_added":null,"published":"2025-11-27"},{"cvss_score":5.3,"headline":"Inefficient Regular Expression Complexity in validatorjs/validator.js","id":"CVE-2021-3765","kev_date_added":null,"published":"2021-11-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-05","vendors":["n/a"]},"summary":"Attackers can bypass URL validation in validator.js to execute XSS or open redirects due to protocol parsing differences with browsers.","url":"https://insights.sbomify.com/CVE-2025-56200/"}