# CVE-2025-56200: validator.js has a URL validation bypass vulnerability in its isURL function

> Attackers can bypass URL validation in validator.js to execute XSS or open redirects due to protocol parsing differences with browsers.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Sep 2025
- **Updated:** 5 Jul 2026
- **Also known as:** CLSA-2026-1784769499, CLSA-2026-1789161501, GHSA-9965-vmph-33xx, MINI-6hx5-73r5-8c3v, MINI-85p5-p97c-w7m9, MINI-98rp-vv2g-9x4v, ROOT-APP-NPM-CVE-2025-56200, UBUNTU-CVE-2025-56200

## What is CVE-2025-56200?

CVE-2025-56200 is a medium-severity cross-site scripting vulnerability in n/a, published on 30 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A URL validation bypass vulnerability exists in validator.js through version 13.15.15. The isURL() function uses '://' as a delimiter to parse protocols, while browsers use ':' as the delimiter. This parsing difference allows attackers to bypass protocol and domain validation by crafting URLs leading to XSS and Open Redirect attacks.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-56200?

2 open source packages ship an affected version, including validator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `validator` | npm | All versions | 13.15.20 |
| `validator` | npm | All versions | 13.15.20 |

Products: Validator Project Validator.

## How do I fix CVE-2025-56200?

Upgrade validator to 13.15.20 or later.

## Is CVE-2025-56200 being exploited?

There is no known exploitation of CVE-2025-56200 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-12758](https://insights.sbomify.com/CVE-2025-12758/): Validator is Vulnerable to Incomplete Filtering of One or More Instances of Special Elements (high 8.7)
- [CVE-2021-3765](https://insights.sbomify.com/CVE-2021-3765/): Inefficient Regular Expression Complexity in validatorjs/validator.js (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-56200 and fix it if it is affected.

What it is: CVE-2025-56200 is a medium-severity cross-site scripting vulnerability in n/a, published on 30 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-56200 in the wild and no public exploit code.

Affected packages and fixed versions:
- validator (npm): affected all versions; fixed in 13.15.20
- validator (npm): affected all versions; fixed in 13.15.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-56200/ (Markdown: https://insights.sbomify.com/CVE-2025-56200/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-56200
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-56200
- OSV: https://osv.dev/vulnerability/CVE-2025-56200

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-56200/
Summaries are generated and may contain mistakes; the official description above is the record.
