{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-56225 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2025-56225 is a high-severity vulnerability in n/a, published on 9 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-56225 and fix it if it is affected.\n\nWhat it is: CVE-2025-56225 is a high-severity vulnerability in n/a, published on 9 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-56225 exists.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-56225/ (Markdown: https://insights.sbomify.com/CVE-2025-56225/index.md)","id":"CVE-2025-56225","markdown":"https://insights.sbomify.com/CVE-2025-56225/index.md","name":"CVE-2025-56225","record":{"aliases":["DEBIAN-CVE-2025-56225","GHSA-qgg6-hj2r-3x43","OESA-2026-1065","OESA-2026-1066","OESA-2026-1067","OESA-2026-1068","OESA-2026-1069","OESA-2026-1070","UBUNTU-CVE-2025-56225","openSUSE-SU-2026:10038-1","openSUSE-SU-2026:11496-1","openSUSE-SU-2026:20291-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"FluidSynth library","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using FluidSynth by providing a maliciously crafted MIDI file that triggers a null pointer dereference.","user_interaction":"not_required","vuln_class":"null_dereference"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fluidsynth","vendor":"fluidsynth"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-476","name":"NULL Pointer Dereference"}],"description":"fluidsynth-2.4.6 and earlier versions is vulnerable to Null pointer dereference in fluid_synth_monopoly.c, that can be triggered when loading an invalid midi file.","ecosystems":["openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Null dereference in n/a","id":"CVE-2025-56225","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"null_dereference","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Memory corruption in n/a","id":"CVE-2025-56226"},"packages":[{"ecosystem":"openSUSE:Leap 16.0","fixed":["2.3.5-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"fluidsynth","purl":"pkg:rpm/opensuse/fluidsynth\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:20291-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.5.2-2.1"],"introduced":["0"],"last_affected":[],"package":"fluidsynth","purl":"pkg:rpm/opensuse/fluidsynth\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10038-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["4.7.4-1.1"],"introduced":["0"],"last_affected":[],"package":"musescore","purl":"pkg:rpm/opensuse/musescore\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11496-1"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2025-56224"},"products":["n/a"],"published":"2026-01-09","related":[{"cvss_score":7,"headline":"Use after free in fluidsynth","id":"CVE-2025-68617","kev_date_added":null,"published":"2025-12-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-12","vendors":["n/a"]},"summary":"An attacker can cause a denial of service in applications using FluidSynth by providing a maliciously crafted MIDI file that triggers a null pointer dereference.","url":"https://insights.sbomify.com/CVE-2025-56225/"}