# CVE-2025-56265: N8N's Chat Trigger component is vulnerable to XSS

> Attackers can execute arbitrary code by uploading a crafted HTML file to the Chat Trigger component in N8N.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2025
- **Updated:** 8 Sep 2025
- **Also known as:** GHSA-v2x8-97xq-8xrr

## What is CVE-2025-56265?

CVE-2025-56265 is a high-severity vulnerability in N8n N8n, published on 8 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3, v1.100.1, and v1.101.1 allows attackers to execute arbitrary code via uploading a crafted HTML file.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2025-56265?

2 open source packages ship an affected version, including @n8n/n8n-nodes-langchain. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@n8n/n8n-nodes-langchain` | npm | All versions | 1.107.0 |
| `@n8n/n8n-nodes-langchain` | npm | All versions | 1.107.0 |

Products: N8n N8n.

## How do I fix CVE-2025-56265?

Upgrade @n8n/n8n-nodes-langchain to 1.107.0 or later.

## Is CVE-2025-56265 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-56265 exists.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-56265 and fix it if it is affected.

What it is: CVE-2025-56265 is a high-severity vulnerability in N8n N8n, published on 8 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-56265 exists.

Affected packages and fixed versions:
- @n8n/n8n-nodes-langchain (npm): affected all versions; fixed in 1.107.0
- @n8n/n8n-nodes-langchain (npm): affected all versions; fixed in 1.107.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-56265/ (Markdown: https://insights.sbomify.com/CVE-2025-56265/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-56265
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-56265
- OSV: https://osv.dev/vulnerability/CVE-2025-56265

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-56265/
Summaries are generated and may contain mistakes; the official description above is the record.
