# CVE-2025-56421: LimeSurvey is vulnerable to SQL injection

> Remote attackers can exploit SQL injection in LimeSurvey to obtain sensitive database information.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 5 Jul 2026
- **Also known as:** GHSA-rccq-2fxq-7x3h

## What is CVE-2025-56421?

CVE-2025-56421 is a high-severity SQL injection vulnerability in Limesurvey Limesurvey, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SQL Injection vulnerability in LimeSurvey before v.6.15.4+250710 allows a remote attacker to obtain sensitive information from the database.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-56421?

2 open source packages ship an affected version, including limesurvey/limesurvey. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `limesurvey/limesurvey` | Packagist | All versions | 6.15.4 |
| `limesurvey/limesurvey` | Packagist | All versions | 6.15.4 |

Products: Limesurvey Limesurvey.

## How do I fix CVE-2025-56421?

Upgrade limesurvey/limesurvey to 6.15.4 or later.

## Is CVE-2025-56421 being exploited?

There is no known exploitation of CVE-2025-56421 in the wild and no public exploit code.

## Other vulnerabilities in Limesurvey Limesurvey

- [CVE-2025-56422](https://insights.sbomify.com/CVE-2025-56422/): Deserialization in n/a (critical 9.8)
- [CVE-2022-48008](https://insights.sbomify.com/CVE-2022-48008/): File upload in n/a (critical 9.8)
- [CVE-2019-25019](https://insights.sbomify.com/CVE-2019-25019/): SQL injection in n/a (critical 9.8)
- [CVE-2020-11455](https://insights.sbomify.com/CVE-2020-11455/): Path traversal in n/a (critical 9.8)
- [CVE-2019-16184](https://insights.sbomify.com/CVE-2019-16184/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-56421 and fix it if it is affected.

What it is: CVE-2025-56421 is a high-severity SQL injection vulnerability in Limesurvey Limesurvey, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-56421 in the wild and no public exploit code.

Affected packages and fixed versions:
- limesurvey/limesurvey (Packagist): affected all versions; fixed in 6.15.4
- limesurvey/limesurvey (Packagist): affected all versions; fixed in 6.15.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-56421/ (Markdown: https://insights.sbomify.com/CVE-2025-56421/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-56421
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-56421
- OSV: https://osv.dev/vulnerability/CVE-2025-56421

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-56421/
Summaries are generated and may contain mistakes; the official description above is the record.
