# CVE-2025-56588: Dolibarr vulnerable to RCE via the computed field parameter

> Attackers can execute arbitrary code remotely via the computed field parameter in the User module configuration of Dolibarr ERP & CRM.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Oct 2025
- **Updated:** 5 Jul 2026
- **Also known as:** GHSA-27hj-48r9-x2vx, UBUNTU-CVE-2025-56588

## What is CVE-2025-56588?

CVE-2025-56588 is a high-severity code injection vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 1 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Dolibarr ERP & CRM v21.0.1 were discovered to contain a remote code execution (RCE) vulnerability in the User module configuration via the computed field parameter.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-56588?

2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | All versions | 21.0.3 |
| `dolibarr/dolibarr` | Packagist | All versions | 21.0.3 |

Products: Dolibarr Dolibarr Erp\/Crm.

## How do I fix CVE-2025-56588?

Upgrade dolibarr/dolibarr to 21.0.3 or later.

## Is CVE-2025-56588 being exploited?

There is no known exploitation of CVE-2025-56588 in the wild and no public exploit code.

## Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm

- [CVE-2022-43138](https://insights.sbomify.com/CVE-2022-43138/): Dolibarr vulnerable to privilege escalation (critical 9.8)
- [CVE-2022-40871](https://insights.sbomify.com/CVE-2022-40871/): Dolibarr vulnerable to Eval Injection (critical 9.8)
- [CVE-2021-33816](https://insights.sbomify.com/CVE-2021-33816/): Dolibarr remote PHP code execution (critical 9.8)
- [CVE-2020-7995](https://insights.sbomify.com/CVE-2020-7995/): Dolibarr Improper Restriction of Excessive Authentication Attempts (critical 9.8)
- [CVE-2013-2091](https://insights.sbomify.com/CVE-2013-2091/): SQL injection in dolibarr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-56588 and fix it if it is affected.

What it is: CVE-2025-56588 is a high-severity code injection vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 1 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-56588 in the wild and no public exploit code.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 21.0.3
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 21.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-56588/ (Markdown: https://insights.sbomify.com/CVE-2025-56588/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-56588
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-56588
- OSV: https://osv.dev/vulnerability/CVE-2025-56588

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-56588/
Summaries are generated and may contain mistakes; the official description above is the record.
