# CVE-2025-56647: @farmfe/core is Missing Origin Validation in WebSocket

> Attackers can steal source code and surveil developers by exploiting missing origin validation in the Farm development server's WebSocket connection.

- **Severity:** Medium 6.5 (`CVSS:3.1/AC:L/AV:N/A:N/C:H/I:N/PR:N/S:U/UI:R`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Feb 2026
- **Updated:** 12 Feb 2026
- **Also known as:** GHSA-p773-8mf4-rjm5

## What is CVE-2025-56647?

CVE-2025-56647 is a medium-severity missing authorization vulnerability in n/a, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

npm @farmfe/core before 1.7.6 is Missing Origin Validation in WebSocket. The development (hot module reloading) server does not validate origin when connecting to a WebSocket client. This allows attackers to surveil developers running Farm who visit their webpage and steal source code that is leaked by the WebSocket server.

Weakness: CWE-1385 (Missing Origin Validation in WebSockets)

## Which versions are affected by CVE-2025-56647?

2 open source packages ship an affected version, including @farmfe/core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@farmfe/core` | npm | All versions | 1.7.6 |
| `@farmfe/core` | npm | All versions | 1.7.6 |

## How do I fix CVE-2025-56647?

Upgrade @farmfe/core to 1.7.6 or later.

## Is CVE-2025-56647 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-56647 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-56647 and fix it if it is affected.

What it is: CVE-2025-56647 is a medium-severity missing authorization vulnerability in n/a, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-56647 exists.

Affected packages and fixed versions:
- @farmfe/core (npm): affected all versions; fixed in 1.7.6
- @farmfe/core (npm): affected all versions; fixed in 1.7.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-56647/ (Markdown: https://insights.sbomify.com/CVE-2025-56647/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-56647
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-56647
- OSV: https://osv.dev/vulnerability/CVE-2025-56647

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-56647/
Summaries are generated and may contain mistakes; the official description above is the record.
