# CVE-2025-56648: Parcel has an Origin Validation Error vulnerability

> Attackers can steal source code from Parcel development servers via malicious websites due to missing origin validation.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Sep 2025
- **Updated:** 26 Jan 2026
- **Also known as:** CLSA-2026-1793296891, GHSA-qm9p-f9j5-w83w

## What is CVE-2025-56648?

CVE-2025-56648 is a medium-severity missing authorization vulnerability in n/a, published on 17 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

npm parcel 2.0.0-alpha and before has an Origin Validation Error vulnerability. Malicious websites can send XMLHTTPRequests to the application's development server and read the response to steal source code when developers visit them.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2025-56648?

2 open source packages ship an affected version, including @parcel/reporter-dev-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@parcel/reporter-dev-server` | npm | From 1.6.1 | 2.16.4 |
| `@parcel/reporter-dev-server` | npm | From 1.6.1 | 2.16.4 |

Products: Parceljs Parcel.

## How do I fix CVE-2025-56648?

Upgrade @parcel/reporter-dev-server to 2.16.4 or later.

## Is CVE-2025-56648 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-56648 exists.

## Other vulnerabilities in n/a

- [CVE-2018-14731](https://insights.sbomify.com/CVE-2018-14731/): Missing Origin Validation in parcel-bundler (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-56648 and fix it if it is affected.

What it is: CVE-2025-56648 is a medium-severity missing authorization vulnerability in n/a, published on 17 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-56648 exists.

Affected packages and fixed versions:
- @parcel/reporter-dev-server (npm): affected from 1.6.1; fixed in 2.16.4
- @parcel/reporter-dev-server (npm): affected from 1.6.1; fixed in 2.16.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-56648/ (Markdown: https://insights.sbomify.com/CVE-2025-56648/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-56648
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-56648
- OSV: https://osv.dev/vulnerability/CVE-2025-56648

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-56648/
Summaries are generated and may contain mistakes; the official description above is the record.
