# CVE-2025-56769: Hutool allows remote code execution (RCE) via the QLExpressEngine class

> Attackers can execute arbitrary code via expression injection in the QLExpressEngine class of the hutool Java library.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2025
- **Updated:** 26 Sep 2025
- **Also known as:** GHSA-gcfh-36x4-mgj6

## What is CVE-2025-56769?

CVE-2025-56769 is a medium-severity code injection vulnerability in n/a, published on 25 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in chinabugotech hutool before 5.8.4 allowing attackers to execute arbitrary expressions that lead to arbitrary method invocation and potentially remote code execution (RCE) via the QLExpressEngine class.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-56769?

2 open source packages ship an affected version, including cn.hutool:hutool-extra. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cn.hutool:hutool-extra` | Maven | All versions | 5.8.40 |
| `cn.hutool:hutool-extra` | Maven | All versions | 5.8.40 |

Products: Hutool Hutool.

## How do I fix CVE-2025-56769?

Upgrade cn.hutool:hutool-extra to 5.8.40 or later.

## Is CVE-2025-56769 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-56769 exists.

## Other vulnerabilities in n/a

- [CVE-2023-42276](https://insights.sbomify.com/CVE-2023-42276/): hutool Buffer Overflow vulnerability (critical 9.8)
- [CVE-2023-42277](https://insights.sbomify.com/CVE-2023-42277/): hutool Buffer Overflow vulnerability (critical 9.8)
- [CVE-2023-24162](https://insights.sbomify.com/CVE-2023-24162/): Dromara Hutool Deserialization of Untrusted Data vulnerability (critical 9.8)
- [CVE-2023-24163](https://insights.sbomify.com/CVE-2023-24163/): Dromara hutool vulnerable to SQL Injection (critical 9.8)
- [CVE-2022-22885](https://insights.sbomify.com/CVE-2022-22885/): Improper Certificate Validation in Hutool (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-56769 and fix it if it is affected.

What it is: CVE-2025-56769 is a medium-severity code injection vulnerability in n/a, published on 25 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-56769 exists.

Affected packages and fixed versions:
- cn.hutool:hutool-extra (Maven): affected all versions; fixed in 5.8.40
- cn.hutool:hutool-extra (Maven): affected all versions; fixed in 5.8.40

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-56769/ (Markdown: https://insights.sbomify.com/CVE-2025-56769/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-56769
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-56769
- OSV: https://osv.dev/vulnerability/CVE-2025-56769

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-56769/
Summaries are generated and may contain mistakes; the official description above is the record.
