CVE-2025-5683 Denial of service in Qt
Attackers can cause a crash in applications using Qt by loading a specially crafted ICNS image file, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-5683?
CVE-2025-5683 is a medium-severity denial of service vulnerability in Qt Qt, published on 5 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
When loading a specifically crafted ICNS format image file in QImage then it will trigger a crash.
This issue affects Qt from versions 6.3.0 through 6.5.9, from 6.6.0 through 6.8.4, 6.9.0. This is fixed in 6.5.10, 6.8.5 and 6.9.1.
Weakness: CWE-770
Which versions are affected by CVE-2025-5683?
It affects 1 product.
Products include Qt Qt.
How do I fix CVE-2025-5683?
Upgrade to a fixed version.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-5683 being exploited?
There is no known exploitation of CVE-2025-5683 in the wild and no public exploit code.
Other vulnerabilities in Qt Qt
Sources
Also known as DEBIAN-CVE-2025-5683, GHSA-5mw2-w8pc-m6p6, MGASA-2025-0208, OESA-2025-1708, OESA-2025-1709, OESA-2025-1794 and 7 more.